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INTRODUCTION 
 

Welcome to the learning programme 

 

Follow along in the guide as the training practitioner takes you through the material. Make 

notes and sketches that will help you to understand and remember what you have learnt. Take 

notes and share information with your colleagues. Important and relevant information and 

skills are transferred by sharing! 

 

 

 

 

 

 

 

 

 

 

 

 

This learning programme is divided into sections. Each section is preceded by a description of 

the required outcomes and assessment criteria as contained in the unit standards specified by 

the South African Qualifications Authority. These descriptions will define what you have to 

know and be able to do in order to be awarded the credits attached to this learning 

programme. These credits are regarded as building blocks towards achieving a National 

Qualification upon successful assessment and can never be taken away from you! 



 Page 3 

 

Programme methodology 
 

 

 

 

 

 

 

 

The programme methodology includes facilitator presentations, readings, individual activities, 

group discussions and skill application exercises. 

Know what you want to get out of the programme from the beginning and start 

applying your new skills immediately.  Participate as much as possible so that the 
learning will be interactive and stimulating. 

The following principles were applied in designing the course: 

 Because the course is designed to maximise interactive learning, you are encouraged 

and required to participate fully during the group exercises 

 As a learner you  will be presented with numerous problems and will be required to fully 

apply your mind to finding solutions to problems before being presented with the 

course presenter’s solutions to the problems 

 Through participation and interaction the learners can learn as much from each other as 

they do from the course presenter 

 Although learners attending the course may have varied degrees of experience in the 

subject matter, the course is designed to ensure that all delegates complete the course 

with the same level of understanding 

 Because reflection forms an important component of adult learning, some learning 

resources will be followed by a self-assessment which is designed so that the learner 

will reflect on the material just completed. 

This approach to course construction will ensure that learners first apply their minds to finding 

solutions to problems before the answers are provided, which will then maximise the learning 

process which is further strengthened by reflecting on the material covered by means of the 

self-assessments. 

Different role players in delivery process 

 Learner 

 Facilitator 

 Assessor 

 Moderator 
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What Learning Material you should have 

This learning material has also been designed to provide the learner with a comprehensive 

reference guide. 

It is important that you take responsibility for your own learning process; this includes taking 

care of your learner material.  You should at all times have the following material with you: 

Learner Guide This learner guide is your valuable possession: 

This is your textbook and reference material, which provides 

you with all the information you will require to meet the exit 

level outcomes.  

During contact sessions, your facilitator will use this guide 

and will facilitate the learning process. During contact 

sessions a variety of activities will assist you to gain 

knowledge and skills.  

Follow along in the guide as the training practitioner takes 

you through the material. Make notes and sketches that will 

help you to understand and remember what you have 

learnt. Take and share information with your colleagues. 

Important and relevant information and skills are transferred 

by sharing! 

This learning programme is divided into sections. Each 

section is preceded by a description of the required 

outcomes and assessment criteria as contained in the unit 

standards specified by the South African Qualifications 

Authority. These descriptions will define what you have to 

know and be able to do in order to be awarded the credits 

attached to this learning programme. These credits are 

regarded as building blocks towards achieving a National 

Qualification upon successful assessment and can never be 

taken away from you! 

Formative Assessment 
Workbook 

 

The Formative Assessment Workbook supports the Learner 

Guide and assists you in applying what you have learnt.  

The formative assessment workbook contains classroom 

activities that you have to complete in the classroom, during 

contact sessions either in groups or individually. 

You are required to complete all activities in the Formative 

Assessment Workbook.  

The facilitator will assist, lead and coach you through the 

process. 

These activities ensure that you understand the content of 

the material and that you get an opportunity to test your 

understanding.  
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Different types of activities you can expect 

To accommodate your learning preferences, a variety of different types of activities are 

included in the formative and summative assessments. They will assist you to achieve the 

outcomes (correct results) and should guide you through the learning process, making learning 

a positive and pleasant experience. 

 

The table below provides you with more information related to the types of activities.  

Types of Activities Description Purpose 

Knowledge Activities 

 

You are required to 

complete these activities 

on your own.  

 

 

 

 

These activities normally test 

your understanding and 

ability to apply the 

information. 

Skills Application 

Activities 

 

You need to complete 

these activities in the 

workplace  

 

 

 

These activities require you 

to apply the knowledge  and 

skills  gained in the 

workplace 

Natural Occurring 

Evidence 

 

You need to collect 

information and samples 

of documents from the 

workplace. 

These activities ensure you 

get the opportunity to learn 

from experts in the industry. 

Collecting examples 

demonstrates how to 

implement knowledge and 

skills in a practical way 
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Learner Administration  

 

 

 

 

 

Attendance Register 

You are required to sign the Attendance Register every day you attend training sessions 

facilitated by a facilitator.  

Programme Evaluation Form  

On completion you will be supplied with a ―Learning programme Evaluation Form‖. You are 

required to evaluate your experience in attending the programme. 

Please complete the form at the end of the programme, as this will assist us in improving our 

service and programme material.  Your assistance is highly appreciated. 

Assessments 

The only way to establish whether a learner is competent and has accomplished the specific 

outcomes is through the assessment process.  Assessment involves collecting and interpreting 

evidence about the learners’ ability to perform a task. 

To qualify and receive credits towards your qualification, a registered Assessor will 

conduct an evaluation and assessment of your portfolio of evidence and competency. 

This programme has been aligned to registered unit standards.  You will be assessed 

against the outcomes as stipulated in the unit standard by completing assessments 
and by compiling a portfolio of evidence that provides proof of your ability to apply the 
learning to your work situation. 

 

 

 

 

 

How will Assessments commence? 

Formative Assessments  

The assessment process is easy to follow. You will be guided by the Facilitator. Your 

responsibility is to complete all the activities in the Formative Assessment Workbook and 

submit it to your facilitator.  

Summative Assessments  

You will be required to complete a series of summative assessments. The Summative 

Assessment Guide will assist you in identifying the evidence required for final assessment 

purposes. You will be required to complete these activities on your own time, using real life 
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projects in your workplace or business environment in preparing evidence for your Portfolio of 

Evidence. Your Facilitator will provide more details in this regard. 

To qualify and receive credits towards your qualification, a registered Assessor will 
conduct an evaluation and assessment of your portfolio of evidence and competency. 

Learner Support 

The responsibility of learning rests with you, so be proactive and ask questions and 

seek assistance and help from your facilitator, if required. 

 

 

 

 

 

 

 

 

Please remember that this Skills Programme is based on outcomes based education principles 

which implies the following: 

 You are responsible for your own learning – make sure you manage your study, 

research and workplace time effectively.  

 Learning activities are learner driven – make sure you use the Learner Guide and 

Formative Assessment Workbook in the manner intended, and are familiar with the 

workplace requirements.   

 The Facilitator is there to reasonably assist you during contact, practical and workplace 

time for this programme – make sure that you have his/her contact details. 

 You are responsible for the safekeeping of your completed Formative Assessment 

Workbook and Workplace Guide  

 If you need assistance please contact your facilitator who will gladly assist you. 

 If you have any special needs please inform the facilitator  
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Learner Expectations  

Please prepare the following information. You will then be asked to introduce yourself to the 

instructor as well as your fellow learners 

 

 

 

 

 

Your name:  

 

 

The organisation you represent:  

 

 

Your position in organisation:  

 

 

What do you hope to achieve by attending this course / what are your course 

expectations? 
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UNIT STANDARD 7567 

Unit Standard Title  

Produce and use spreadsheets for business  

NQF Level: 3 

Credits: 5 

Purpose  

People credited with this unit standard are able to:  

 Plan and design computer spreadsheet documents to solve a busi-ness problem  

 Format data in a spreadsheet.  

 Create graphs  

 Write macros  

 Solve problems using a spreadsheet  

Learning assumed to be in place 

The credit value of this unit is based on a person having the prior knowledge and skills to use a 

PC, to produce and use spread-sheets using basic functions, and an understanding of basic 

business principles and practises  

Specific Outcomes and Assessment Criteria 

Specific Outcome 1: Plan and design computer spreadsheet documents to solve a business 

problem 

Assessment Criteria 

 The problem is identified as being solvable by a spreadsheet 

 The spreadsheet is designed and documented in keeping with the nature of the problem 

Specific Outcome 2: Produce a computer spreadsheet file to solve a business problem 

Assessment Criteria 

 Data is entered into the spreadsheet using labels and values 

 Data is formatted to produce the required spreadsheet in terms of cell width, alignment, 

number and date and time formats 

 Spreadsheet formulae are applied in order to produce the required spreadsheet in terms 

of statistical, time and date, financial and logical function 

 Absolute cell referencing is used in order to copy formulae across and down 

 Template files are created, used and documented to meet the user requirements 

 Data integrity practices are demonstrated in terms of comparison with original 

information sources, audited formulae, check-totals and sort 

 The spreadsheet contains cells, which are sorted numerically and alphabetically 

Specific Outcome 3: Use a computer spreadsheet file to solve a business problem 

Assessment criteria 

 Cell ranges within the spreadsheet are charted to meet user requirements 

 The problem is solved by the spreadsheet created 
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 What if" exercises are applied to the spreadsheet in order to accommodate changes in 

requirements 

 Where available, the use of the onscreen help facility is demonstrated 

 File management techniques are demonstrated in terms of creating, naming, saving, 

copying, renaming, deleting, locating directory (folder), displaying directory contents 

printing and relocating 

 The file is previewed and printed using page setup appropriate to the layout: Showing 

gridlines, setting printing range, shrinking to one page, alignment. Headers and footers 

Specific Outcome 4: Manipulate the data in a spreadsheet 

Assessment criteria 

 The appearance of spreadsheet is modified to user requirements using formatting 

facilities: Alignment, cell widths, text style, font, colour, number, date and time formats 

 Selected cells within an existing spreadsheet file are sorted numerically and 

alphabetically 

Unit Standard Essential Embedded Knowledge 

N/A 

Critical Cross-field Outcomes (CCFO) 

 Identify and solve problems 

 Work effectively with others as a member of a team, group, organisation and 

community 

 Organise and manage oneself and one`s activities responsibly and effectively.  

 Collect, organise and critically evaluate information 

 Communicate effectively using visual, mathematical, and language skills in modes of 

oral and written presentations 

 Use science and technology effectively and critically (showing responsibility towards the 

environment and health of others).  

 Demonstrate an understanding of the world as a set of related systems 

 Contribute to the full personal development of each learner and the social and economic 

development of society at large, by making it the underlying intention of any 

programme of learning to make an individual aware of the importance of:  

 reflecting on exploring a variety of strategies to learn more effectively  

 participating as responsible citizens in the life of local, national and global 

communities  

 being culturally and aesthetically sensitive across a range of social contexts  

 exploring education and career opportunities and  

 developing entrepreneurial opportunities 
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PLAN AND DESIGN A SPREADSHEET 

Specific Outcome 

Plan and design computer spreadsheet documents to solve a business problem 

 

 

Assessment Criteria 

 The problem is identified as being solvable by a spreadsheet 

 The spreadsheet is designed and documented in keeping with the nature of the problem 
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Excel is a spreadsheet program. It adds long columns or rows of figures for you. You can also 

put together a list of clients or contacts with all their details: addresses, telephone numbers, 

postal addresses, etc. 

The basic working environment in Excel is a workbook that can contain one or more 

worksheets. (Remember, in Word we spoke about a document - in Excel it is called a 

worksheet.) 

A worksheet is similar to an accountant’s ledger, with numbers; text and calculations lined up 

in columns and rows.  However, unlike in an accountant’s ledger, Excel will do the calculations 

for you. 

Excel also makes it easier for you to change, delete or add information. You can also arrange 

multiple worksheets within a workbook – for example, you can place all the worksheets for one 

client 

Other examples of spreadsheet programs are: Lotus 1,2,3 and Quattro Pro. 

What Is An Electronic Spreadsheet? 

Traditionally, people used a ruled columnar pad, a pencil and eraser and a calculator when 

doing bookkeeping. A spreadsheet, called a workbook in Excel, replaces these tools. The 

program uses a format very similar to an analysis book which can be bought in any stationery 

shop: it looks like a large piece of paper with columns and rows on which you do your work.  
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PRODUCE A SPREADSHEET 
 

Specific Outcome 

Produce a computer spreadsheet file to solve a business problem 

 

 

Assessment Criteria 

 Data is entered into the spreadsheet using labels and values 

 Data is formatted to produce the required spreadsheet in terms of cell width, alignment, 

number and date and time formats 

 Spreadsheet formulae are applied in order to produce the required spreadsheet in terms 

of statistical, time and date, financial and logical function 

 Absolute cell referencing is used in order to copy formulae across and down 

 Template files are created, used and documented to meet the user requirements 

 Data integrity practices are demonstrated in terms of comparison with original 

information sources, audited formulae, check-totals and sort 

 The spreadsheet contains cells, which are sorted numerically and alphabetically 
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Changing The Position Of Text And Numbers In A 
Cell 

Aligning Text And Numbers In A Cell  

You can change the position of text and numbers in a cell. You can also choose whether to 

align right, left or centre. 

Using The Format, Cells Menu 

Select column A and then select the Format, Cells menu. Click the alignment tab and study 

the screen. You have certain boxes with a number of choices. The horizontal choices are:  

 General: will put the text to the left and the numbers to the right; 

 Left:  will put all contents to the left 

 Centre: arranges contents in the cell centre 

 Right:  places all the content to the right side 
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 Select the Centre option and click OK.  

See how your cell contents are arranged in the centre of the cells. 

 Now select the Right option and click OK.  

The contents of the cells will be aligned to the right.  

 While your column is still selected, click the Left option and OK.  

The contents of the cell will be aligned to the left.  

 

  

 

 

 

Centre Text Across Columns 

 

 
 

Using the toolbar: Select Column A and click the 

left align button on the formatting toolbar. See 

how the text automatically aligns to the left. Now 

click the centre button and the right align button 
to see the text centre and then align to the right. 

Using the toolbar: Select the cells you want to 

centre and click on the Merge and Centre button of 

the formatting toolbar. See how the text is centred 

in the row 
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Wrap Text 

To display multiple lines of text within a cell:  

 Select the cells you want to format. 

 On the Format menu, click Cells, and then click the Alignment tab.  

 Under Text control, select the Wrap text check box.  

 You can also shrink the font size to show all data in a cell  

Rotate Text In A Cell 

The data in a column is often very narrow while the label for the column is much wider. 

Instead of creating unnecessarily wide columns or abbreviated labels, you can rotate text and 

apply borders that are rotated to the same degree as the text.  Select the cells in which you 

want to rotate text. 

 On the Format menu, click Cells, and then click the Alignment tab. 

 In the Orientation box, click a degree point, or drag the indicator to the angle you want.  

 To display text vertically from top to bottom, click the vertical Text box under 

Orientation.  

 

 

 

 

 

 

 

 

 

 

Using the format menu: Select the cells and 

click on format, cells. Click on the alignment tab 

and then select Centre across selection. The text 
will be centred in the row. 
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Adjust Column Width And Row Height 

Exercises 19: Column Width  

The standard width of a column is 8,43 characters.   

 

 

 

Using the Format menu: Select column A, or any cell from column A and select the Format, 
Column menu and click on width. Enter 15 in the dialogue box to increase the width of 

column C and click OK. The width will have increased on your screen. 

 

    

 

 
 

Excel offers two methods of changing the 

column width: through the format menu or by 

using the mouse. 

Point the mouse at the vertical line to the right 

of the column header until it turns into a 

double-headed arrow, then click and drag 
the mouse to the right or left 

To change the column width of the entire 

sheet, Click the Select All button, in the top 

left hand corner of the worksheet, where the 

rows and columns meet.  Select the format, 

column menu; enter the desired width and 

click OK. The column width for the entire 
sheet will change 
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Exercises: Row Height 

 

 

   
 

 

Exercise 20 

 Point the mouse at the vertical line to the right of the column header of column B until it 

turns into a double-headed arrow, then click and drag the mouse to the right until the 

text in the cells is fully visible. 

 Select Row 1. Select the Format, Row menu and click height. Enter a height of 25 in the 

box and click OK. The height of the row will increase. 

 

Enter Data Into Cells 

 

Entering data into cells: When you type numbers into a cell, 

they are automatically aligned to the right. If the number is 

too long, Excel will automatically widen the column. To enter a 

negative amount, either type a minus  (-) before the amount 
or enclose it within a parentheses (1234).  

Format menu: Select the Row that you 

want to change, select the Format, Row 

menu and click height. Enter the height you 

require into the dialogue box and click OK. 

Using the Mouse: Point the mouse to the 

vertical line at the bottom edge of the row 

heading until it turns into a double-headed 

arrow, then click and drag the vertical line to 

the desired height.  

To change the row height of the entire sheet, Click the Select All button, in the top left 

hand corner of the worksheet, where the rows and columns meet.  Select the format, row 
menu; enter the desired height and click OK. The row height for the entire sheet will change. 
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 Now click in Cell A1 to select it, then type 500 and press enter. In cell A2 type (minus) 

–250 and press the down arrow to select cell A3. In cell A3 type: 12345678912. See 

how Excel widens the column for the last set of numbers. Please note that you have to 

tell the PC when you have finished entering data in a cell by moving out of the cell. This 

is what you do when you press Enter or use the keyboard arrows. 

 When you open a new worksheet, all the cells have general format. The format of the 

cell determines what the numbers, text, dates and so on in the cell look like after you 

have entered data into a cell.  

A general format means that the cells have no specific number format. Let's find out what this 

means. In cell B1 type: Mrs B. Otto; in cell B2 type PO Box 1620; in cell B3 type Timbuktu; in 

cell B4 type the postal code 0026. See what happens to the postal code? In order to display 

the postal code correctly, we have to change the format of the cell. This will be done in the 

next step. 

 

 

 

The format of a cell is changed via the 

format menu on the menu bar. Before we 

can change the format of a cell, we first 

have to tell the PC which cell we want to 

change. Click on cell B4, where the postal 

code should be. Then click on the format 

menu and click on cells.  
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Currency Format 

Exercise 21 

 

In your practice file enter the following amounts in cells C1 to C5: C1: 28443; C2: 31296; C3: 

8543; C4: 12; C5: 96.  

 

   

 

 Then select these cells, click the Format menu from the menu bar and click cells.  Click 

on the Numbers tab and then click on the currency category.  The explanation reads: 

"Currency formats are used for general monetary values." 

 Set the number of decimal places to zero and the currency to R English. 

 Select the first figure in red in the box as the format for negative numbers. Click OK.  

The explanation given says that: "Number 

is used for general display of numbers." 

Click OK and watch what happens. Oops, 

this is not what you wanted! But at least 

now you know that the Numbers format 

gives two decimal points and that it is 
used for a general display of numbers. 
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Accounting Format 

Exercise 22 

 In Cells D1 to D5, enter the following numbers: D1: 86236;   D2: 789654;   D3: 789;   

D4: 86;   D5: 98746.   

 Once again, select Cells D1 to D5; click the format menu, click cells and then click the 

number tab, if necessary.  

 Click the accounting category and look at the rest of the menu. You will see that you 

now have different options from the previous Exercises, when you clicked the currency 

category. You can either reduce or increase decimal places and select a different 

symbol.  

 The explanation reads: "Accounting formats line up the currency symbols and decimal 

points in a column." 

 Change the decimal places option to two; click on OK. 

Now you can see that all the R signs are aligned underneath each other.   

Exercise 23 

Put simply, a budget is a statement of your income and expenses, showing you how much 

money you have left once you have paid all your debts. Income is of course all your earnings: 

salary, commission, interest, maintenance, etc. Expenses are everything you have to pay: 

house rent, water and lights, telephone, school fees, transport, accounts, etc. 

 Complete your monthly budget, or an imaginary one and save it to the hard drive. 

Name your workbook Budget and add your name.  

Entering Formulas Into Cells 

You ALWAYS begin a = in the cell where you want the answer! 

Excel uses the following arithmetic operators that you will find on your numeric keyboard on 

the right hand side of the keyboard: 

 To Add use the  + (plus)  

 To Subtract use the  - (minus) 

 To Multiply use the  * (asterisk) 

 To Divide use the  / (forward slash) 

Click on sheet 3 in your workbook. 

See how the appearance of the cells 
has changed. 
 

If you look at the formula bar, the number 

appears unformatted (it does not show the 

R in front of the amounts). Excel uses the 

number in the formula bar when 

performing any calculations on this cell, in 

other words it uses the number only, not 
the currency.  



 Page 22 

Exercise 24 

 In cell A1 type 250; in cell A2 type 320; in cell A3 type 125. 

 Start your calculation (your sum) by entering an = in cell A4 

 Click cell A1 and press + .See how the formula shows in cell A4 

 Click cell A2 and press+ .See how the formula shows in cell A4 as well as the Formula 

Bar 

 Click cell A3 and press Enter  - DO NOT PRESS + IN  CELL A3!!! Press 

Enter!!! 

 The answer will display in cell A4. 

 If you press + and then Enter in cell A3, an error message will display. You can click on 

Yes and Excel will make the corrections as proposed, or you can click No and make the 

corrections yourself. 

   

Error Messages 

When you are adding in Excel, it is similar to adding on a calculator. You will type + in all the 

cells except the last one, where you press enter. Excel will automatically calculate and display 

your answer in the cell nominated by you, where you typed the =. 

If a formula cannot properly evaluate a result, Microsoft Excel will display an error value. Each 

error type has different causes, and different solutions. Error messages display in two ways: 

via the Office Assistant as in the example above and then as a message in a cell. 

##### Occurs when a column is not wide enough, or a negative date or time is used. 

Enlarge the column 

#VALUE! Occurs when the wrong type of argument or operand is used. There is 

something wrong with your formula, check the formula again. Also check that 

you used the correct cell formatting. 

#NAME? Occurs when Microsoft Excel doesn't recognize text in a formula. Usually this 

happens when you used a label in a formula, without labels being allowed. This 

is covered later in the manual. 

#REF! Occurs when a cell reference is not valid 

This lesson is important, because if you do not do the calculations in the right sequence, Excel 

will not be able to display the answer. 

Add A Column Using The Autosum Button 

Exercise 25 

 You will find the Autosum button on the toolbar. Autosum will add totals in columns or 

rows for you: 

 Click and drag down the cells in the column that you wish to add. End one cell below 

the last number.  Then click the AutoSum button on the toolbar.  

 Excel will add the total of the column automatically.  Columns can only be added from 

the top to the bottom and rows from the left to the right 
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 You are still working in sheet 3, so enter the following amounts in column C: 

  C1:1230; C2: 4387; C3:2598; C4: 1121; C5: 7683; C6: 5576. 

 

 

Adding Using The SUM Function  
You can find the SUM function in two ways: through the Paste Function button or through the 

SUM function:  

 

The SUM function appears in the Name box as soon as you click on the = sign on the formula 

bar. 

Click and drag from cell C1 to cell C7. Click on the 

Autosum button. The answer will be displayed in 

cell C7 
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Exercises  

 In column D enter the following amounts: D1 : 121; D2: 354; D3 no amount; D4: 478; 

D5: 299; D6: 35; D7: 99. 

 

 

 

 

 

 

 

 

 Click in cell D8 and then click the Paste Function button on the toolbar.  

 In the FunctIon Name box select SUM and click OK. 

 In Number 1 of the SUM box, type the following: D1:D7.  

 The Name box will now display the word SUM and the formula bar will display the 

following: 

 =SUM (D1:D7) 

 This is the correct way of using the SUM function. We will discuss functions again later 

in the manual 

 Click OK and the answer will be displayed in cell D8. 
 

 

Exercises: Using The Sum Function In Rows 

You can, of course, also use the Sum Function to do calculations in rows rather than in 

columns. 

 In row 18, enter the following amounts: cell A18 : 257; cell B18 :799; cell C18 147. 

 Click in cell D18, click the = sign on the formula bar, select Sum in the name box and 

click OK. 

 In Number 1 of the Sum box, type A18:C18 and click OK. 

 The answer will be displayed in cell D18. 
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Subtracting 

Exercise 26 

The procedure to subtract is the same as to add: click the cell where you want the answer and 

then process the calculation. 

Remember, to subtract use the - (minus) on the numeric keyboard. 

 In cell B6 type 115. Click in cell B7 and type =. 

 click cell B5, press - (minus) on the numeric keyboard 

 Click cell B6 and press Enter 

 The answer will be displayed in cell B7 

Multiplication 

Exercise 27 

To multiply, use the * (asterisk) on the numeric keyboard.  

 In cell  F1 enter 247, cell F2: 23, cell F3: 3.  

 Click on cell F4 and enter =  

 Click on cell F1 and type *, click on  cell F2 and type *  

 Click cell F3 and press Enter. The answer will be displayed in cell F4. 

Division 

Exercises 28 

To divide, use the / (forward slash) on the numeric keyboard. 

 Enter the following amounts: cell A20: 8585; cell B20: 123. 

 Click on cell C20, enter = . 

 Click cell A7 and enter /, click cell B7 and press enter. 

 The answer will be displayed in cell C20 
 

Labels And Values 

Labels  

Worksheets often have labels (text) at the top of each column and to the left of each row that 

describe the data within the worksheet. You can use these labels within formulas when you 

want to refer to the related data. You can also create descriptive names that are not labels on 

the worksheet to represent cells, ranges of cells, formulas, or constants. 

By default, Microsoft Excel does not recognize labels in formulas. To use labels in formulas, 

click Options on the Tools menu, and then click the Calculation tab. Under Workbook 

options, select the Accept labels in formulas check box. 

Use labels to represent cells   When you create a formula that refers to data in a 

worksheet, you can use the column and row labels in the worksheet to refer to the data 

For example, the following example contains columns labelled Product 1, Product 2, and 

Product 3. To calculate the total value for the Product 1 column, use the formula =SUM 

(Product 1). 
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Or if you need to refer to the Product 3 amount for the East division (that is, the value 

110.00), you can use the formula =Product 3 East. The space in the formula between "Product 

3" and "East" is the intersection operator. This operator designates that Microsoft Excel should 

find and return the value in the cell at the intersection of the row labelled East and the column 

labelled Product 3.  

 

 

Entering Text/Labels 
 Text can be any combination of numbers and characters 

 Labels can contain numbers and may begin with numbers 

 If you start a label with numbers, it will change to a label as soon as a label character is 

typed 

 Any set of characters entered into a cell that Excel does not interpret as a number, 

formula, date, time, logical value or error value is interpreted as text 

 Text can contain any string of up to 240 characters or numbers 

 Numbers may appear in labels, but they cannot be manipulated arithmetically 

 If you want to enter a number as text, e.g. a postal code, precede the entry with and 

apostrophe. The number will then align to the left of the cell 
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Values 
 There are two types of information that can be stored in cells in the worksheet.  

 Constant value: data that is typed directly into the cell. It can be numeric, or text. 

Constant values do not change unless you select the cell and edit the value yourself. 

 A formula is a sequence of values, cell references, names, functions, or operators that 

produces a new value from existing values. Formulas always begin with an equal = 

sign. A number that is produced as the result of a formula can change when other 

values in the worksheet changes.  

Entering Numbers/Values: 
 A number entry can contain only numerals (0-9), a leading negative (-), positive (+), 

equal (=) or dollar ($) sign; a trailing percent sign (%) or an E (scientific notation).  All 

other combinations of numbers and nonnumeric characters are treated as text. 

 To enter a fraction, type a 0 then press the space bar and enter the fraction:  

   

 

 It is better to use a negative sign (-) rather than a parenthesis (()) to indicate a 

negative number. 

 You cannot include spaces and commas in numbers, the decimal point is a full stop. 

 Excel keeps track of up to 15 decimal places, the formula bar shows only 9 

 An entry can end with % that tells Excel to divide the preceding value by 100. 

Number Formats 

Excel contains many built-in number formats you can choose from: 

 The General format is the default number format. For the most part, what you enter in 

a cell that is formatted with the General format is what is displayed. However, if the cell 

is not wide enough to show the entire number, the General format rounds numbers with 

decimals and uses scientific notation for large numbers.  

 Number format is used for general display of numbers. 

 Currency formats are used for general monetary values 

 Accounting formats line up the currency symbols and decimal points in a column 

 Date formats display date and time serial numbers as date values. Use time formats to 

display only the time portion 

 Text format cells are treated as text even when a number is displayed in the cell. The 

cell is displayed exactly as entered 

 Percentage formats multiply the cell value by 100 and displays the result with a 

percentage symbol. Numbers above 1 are automatically entered as percentages; and 

numbers below 1 are converted to percentages by multiplying by 100. For example, 

entering 10 results in 10%, and entering .1 results in 10%. To have all numbers 
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converted by multiplying by 100, on the Tools menu, click Options, click the Edit tab, 

and then clear the Enable automatic percent entry check box. To quickly display 

numbers as percentages of 100, click Percent Style on the Formatting toolbar 

 The Special category includes formats for postal codes and phone numbers. The postal 

codes are formatted for use in the USA, unfortunately, and will not display SA postal 

codes in the desired format. You can use either the text format for this, or create a 

custom format. 

Change How A Number Looks Without Changing The Number 

You can use number formats to change the appearance of numbers, including dates and times, 

without changing the number behind the appearance. For example, you can display a number 

such as .08 as 8%. 

 Select the cells you want to format.  

 On the Format menu, click Cells, and then click the Number tab.  

 In the Category list, click a category, and then select the options you want. 

Reset A Number Format 

 Select the cells you want to format.  

 On the Format menu, click Cells, and then click the Number tab.  

 In the Category list, click General. 

Increase Or Decrease The Number Of Decimal Places Shown 

 Select the cells you want to format. 

 On the Formatting toolbar, do one of the following:  

 To display fewer digits after the decimal point, click Decrease Decimal  

 To display more digits after the decimal point, Increase Decimal  

Show Or Hide The Thousands Separator In A Number 

 Select the cells you want to format.  

 On the Format menu, click Cells, and then click the Number tab.  

 In the Category list, click Number. 

 Select or clear the Use 1000 separator (,) check box. 

 To quickly add commas to separate thousands, select the cells, and then click Comma 

Style on the Formatting toolbar. 

Add Or Remove A Currency Symbol 

 Select the cells you want to format. 

 On the Format menu, click Cells, and then click the Number tab.  

 In the Category list, click Currency.  

 In the Symbol list, do one of the following:  

 To add a currency symbol, select the one you want.  

 To remove a currency symbol, click None.  

Display Leading Or Trailing Zeros In A Number 

 You can use custom number formats to retain leading zeros in numbers that you enter.  

 Select the cells you want to format. 

 On the Format menu, click Cells, and then click the Number tab.  
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 To display    Use this code 

 12 as 00012 and 123 as 00123  00000 

 12 as 00012 and 123 as 000123  "000"# 

 123 as 0123    "0"# 

 8.9 as 8.900   #.000 

 .631 as 0.6    0.# 

 In the Category list, click Custom. 

 In the Type box, edit the number format codes to create the format you want.  

Naming Cells And Cell Ranges 

Name A Cell Or A Range Of Cells 

You can use range names in place of cell references in formulas. Instead of listing the 

references for the range, you can use its name. Names can make your formulas easier to 

understand if you need to go back and find out what you did. 

 Select the cell, range of cells, or nonadjacent selections that you want to name. 

 Click the Name box at the left end of the formula bar. 

 Type the name for the cells. Press ENTER.  

Guidelines For Naming Cells, Formulas, And Constants  
 The first character of a name must be a letter or an underscore character. Remaining 

characters in the name can be letters, numbers, periods, and underscore characters 

 Names cannot be the same as a cell reference, such as Z$100 or R1C1. 

 Can more than one word be used?   Yes, but spaces are not allowed. Underscore 

characters and periods may be used as word separators — for example, Sales_Tax or 

First. Quarter. 

 How many characters?   A name can contain up to 255 characters. 

 If a name defined for a range contains more than 253 characters, you cannot select it 

from the Name box. 

 Are names case sensitive?   Names can contain uppercase and lowercase letters. 

Microsoft Excel does not distinguish between uppercase and lowercase characters in 

names. For example, if you have created the name Sales and then create another name 

called SALES in the same workbook, the second name will replace the first one. 
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Formulas  
Performing calculations is one of the main uses of spreadsheets. Excel allows you to build 

complex formulas using arithmetic operators and predefined functions. 

A formula is a calculation designed to produce a particular result. A formula can use constant 

number values or references to values stored in cells on the worksheet. Excel includes many 

built-n functions to help you create formulae that perform complex calculations easily.  

Entering formulas  

A formula is started by entering the = sign in a cell: 

 

 

 

=B4+D7 

 

 

Formula Elements 

= Begins a formula. The + or – signs may be used in place of = if the next 

element is a cell reference, but not if it is a function name. 

Brackets ( ) Used to denote precedence in calculating sections of the formula and to 

enhance function ranges 

Cell References A location on the sheet containing a value to work with. Storing values in 

cells rather than in the formula makes a spreadsheet much easier to 

maintain 

Arithmetic Operators + Add; - Subtract; * Multiply; / Divide; % Calculate a percentage 

Constant Number. This will remain the same until the value is changed in the 

formula. 

Worksheet Functions Words such as SUM, COUNT, AVERAGE and many others that perform 

specialised arithmetic 

Range Reference the starting and ending cell of a group of cells enclosed in brackets. When 

the cells are contiguous, for example SUM (A1:A20) they are separated 

by a colon (:). When the cells are non-contiguous, for example 

SUM(A1,A5,A15,A20), they are separated by a comma (,). 

Constructing formulas 

The structure or order of the elements in a formula determine the final result of the 

calculation. Formulas in Microsoft Excel follow a specific syntax, or order, that includes an 

equal sign (=) followed by the elements to be calculated (the operands), which are separated 

by calculation operators. Each operand can be a value that does not change (a constant 

value), a cell or range reference, a label, a name, or a worksheet function. 

Excel performs the operations from left to right — according to the order of operator 

precedence — starting with the equal sign (=).  

Cell References 

Formula 

indicator Arithmetic 

Operator 
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The order in which Microsoft Excel performs operations in 
formulas 

If you combine several operators in a single formula, Microsoft Excel performs the operations 

in the order shown in the following table. For example, if you want to add and multiply in the 

same formula, Excel will first multiply and then add. See the example shown below. 

The following formula produces 11 because Excel calculates multiplication before addition. The 

formula multiplies 2 by 3 and then adds 5 to the result. :  

=5+2*3 

You can control the order of calculation by using parentheses to group operations that should 

be performed first. 

So, you can use parentheses to change the syntax. In the example below, Excel adds 5 and 2 

together and then multiplies the result by 3 to produce 21. 

=(5+2)*3 

If a formula contains operators with the same precedence — for example, if a formula contains 

both a multiplication and division operator — Excel evaluates the operators from left to right. 

To change the order of evaluation, enclose the part of the formula to be calculated first in 

parentheses. When you want to subtract and add, for example, Excel will do it in the order you 

enter it in your formula. Excel will first subtract 230 from 531 and then add 434. 

=531-230+434 

Calculation operators in formulas  

Operators specify the type of calculation that you want to perform on the elements of a 

formula. Microsoft Excel includes four different types of calculation operators: arithmetic, 

comparison, text, and reference. 

The order in which Excel will perform calculations: 

Operator Description 

: (colon)  

  (single space) 

, (comma) Reference operators 

– Negation (as in –1) 

% Percent 

^ Exponentiation 

* and / Multiplication and division 

+ and –  Addition and subtraction 

& Connects two strings of text (concatenation) 

= < > <= >= <> Comparison 

 

Arithmetic operators.These are the ones you will use the most. To perform basic 

mathematical operations such as addition, subtraction, or multiplication; combine numbers; 

and produce numeric results, use the following arithmetic operators. 
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Arithmetic operator Meaning Example 

+ (plus sign) Addition 3+3 

– (minus sign) Subtraction 

Negation 3–1 –1 

* (asterisk) Multiplication 3*3 

/ (forward slash) Division 3/3 

% (percent sign) Percent 20% 

^ (caret) Exponentiation 3^2 (the same as 3*3) 

 

When you create a formula that contains a function, the Formula Palette helps you enter 

worksheet functions. As you enter a function into the formula, the Formula Palette displays the 

name of the function, each of its arguments, a description of the function and each argument, 

the current result of the function, and the current result of the entire formula. To display the 

Formula Palette, click Edit Formula in the formula bar. 

 

  

 

 

 

 

Editing formulas 

You can use the Formula Palette to edit functions in formulas. Select a cell that contains a 

formula, and then click Edit Formula to display the Formula Palette. The first function in the 

formula and each of its arguments appear in the palette. You can edit the first function or edit 

another function in the same formula by clicking in the formula bar anywhere within the 

function. For example, you can change the cell references in the example below:  

Cell and Range References 

A reference identifies a cell or a range of cells on a worksheet and tells Microsoft Excel where 

to look for the values or data you want to use in a formula. With references, you can use data 
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contained in different parts of a worksheet in one formula or use the value from one cell in 

several formulas. You can also refer to cells on other sheets in the same workbook, to other 

workbooks, and to data in other programs. References to cells in other workbooks are called 

external references. References to data in other programs are called remote references. 

Relative references 

When you create a formula, references to cells or ranges are usually based on their position 

relative to the cell that contains the formula. In the following example, cell B6 contains the 

formula =A5; Microsoft Excel finds the value one cell above and one cell to the left of B6. This 

is known as a relative reference. 

When you copy a formula that uses relative references, Excel automatically adjusts the 

references in the pasted formula to refer to different cells relative to the position of the 

formula. In the following example, the formula in cell B6, =A5, which is one cell above and to 

the left of B6, has been copied to cell B7. Excel has adjusted the formula in cell B7 to =A6, 

which refers to the cell that is one cell above and to the left of cell B7. 

Absolute references 

If you don't want Excel to adjust references when you copy a formula to a different cell, use an 

absolute reference. For example, if your formula multiplies cell A5 with cell C1 (=A5*C1) and 

you copy the formula to another cell, Excel will adjust both references. You can create an 

absolute reference to cell C1 by placing a dollar sign ($) before the parts of the reference that 

do not change. To create an absolute reference to cell C1, for example, add dollar signs to the 

formula as follows: 

=A5*$C$1 

Move or copy a formula 
 When you move a formula, the cell references within the formula do not change.  

 When you copy a formula, absolute cell references do not change; relative cell 

references will change.  If you do not want the cell references to change, use absolute 

cell references.  

Set Up Data Entry Validation 
Data validation is setting up criteria for any data entered into the cell. If the data entered does 

not match the criteria, an error message can be displayed and the data entry cancelled. 

Validation checks data entered either manually or by a macro and also applies to the results of 

formulas. 

To Apply Data Validation To A Cell 
 Select the cell(s) to be validated 

 From the Data menu, select Validation...  

 The Data Validation dialogue box is displayed. 

 Select the Settings tab 

 From the Allow: box, select the type of data that you want to allow in the cell 

 Additional selection boxes are displayed depending on the validation type. 



 Page 34 

 

Example of whole number validation 

 

Example of list validation 

Various selections are available. You can specify a range of whole numbers, decimals, dates or 

times. You can limit selections to items on a list or restrict the length of text entries. If you 

select the Custom option, you can validate data based on the results of a formula. 

 From the Data: list box, select an operator to use to evaluate criteria 

For example, you can force the cell entry to match one value, a range of values, or make it 

greater or less than a value. You can prevent specific entries using the Not Equal To 

operator. 

The list boxes under Data: change depending on the values selected in Allow: and Data:, but 

they are all used to enter the data value(s) to match. 

 Type values into the boxes 

OR 

 Type a range containing the values to test 

OR 

 Click the worksheet selection icon  and select the range where the criteria values are 

placed then press Enter  

Tip To type a list, separate items in the list using a comma. 

If you select the Custom option, you can type or select a 

formula to evaluate data entry. 

 

 Click the Ignore blank check box if the cell may be left blank 

 Select any other options appropriate to the input type 

For example, if you limit data to a list, you can display the list as a drop-down control in the 

cell by selecting In cell dropdown. 

 Click OK 

Tip To remove data validation, click Clear All. 
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To Create A Data Validation Input Message 

A data input message can be set for each cell that is validated. As soon as the cell is selected 

the Input Message box is displayed. An option not to display the message is also contained 

within the dialogue box. 

 From the Data Validation dialogue box, select the Input Message tab 

 
Data Validation dialogue box - Input Message tab 

 In the Title: box, enter a title for the message window 

 In the Input Message: box, type the message about entering data in the cell 

 Click OK 

 The Input message is displayed as soon as the cell is selected. 

 
Input Message 

To Create A Data Validation Error Message 

An error message can be set for each validated cell. There are three types of error message. 

 Stop will not accept an incorrect entry at all. 

 Warning allows an incorrect entry to be accepted or rejected. 

 Message displays the message and accepts the incorrect entry. 
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As soon as data entry is completed, if it is not within the allowable range, the Error Alert 

message box is displayed. An option not to display the message is also contained within the 

dialogue box. 

 From the Data Validation dialogue box, select the Error Alert tab 

 
Data Validation dialogue box - Error Alert tab 

 In the Style: box, select the message type 

 In the Title: box, enter a title for the message window 

 In the Error message: box, type a helpful message describing the error and how to 

correct it 

 Click OK 

 When incorrect data is entered into the cell the error message is displayed. 

 
Data Validation message 

Validate A Worksheet 

If you choose to allow invalid entries, you can highlight them on the worksheet.  
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To Highlight Invalid Data 
 From the Tools menu select Formula Auditing then from the submenu, select Show 

Formula Auditing Toolbar 

 The Formula Auditing toolbar is displayed. 

 Click the Circle Invalid Data button  

 A red circle is displayed around cells containing invalid data. 

 
Invalid data highlighted 

To Remove Invalid Data Highlights 

 Correct the entry in the cell then click Circle Invalid Data  again 

OR 

 On the Formula Auditing toolbar, click Clear Validation Circles  

The red circles are removed from around all cells containing invalid data, but the data in them 

remains unchanged. 

Exercise 29 

 Open the workbook VALIDATION 

 In cell B7 (Overheads Growth) create a validation entry 

 Set these validation settings: Whole Number, Less than 1; and switch off Ignore 

blank 

 Set the Input Message title to "Input Overheads" and the message to "Enter a fraction 

such as .15, or a percentage such as 15%" 

 Set the Error Alert to Stop; title to "High Overheads", and the message as 

"Unrealistic figure, please re-enter." 

 In cell B7 enter the number 2 

 Reset the validation Error Alert to Warning 

 In cell B7 enter the number 2, and accept the number 

 Display the Formula Auditing toolbar 

 Use the Circle Invalid Data button  to highlight the number 2 in cell B7 
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 Close the file without saving it 

To distribute data to people who do not have access to the Microsoft Excel application (or are 

using a different version of it), you can save a workbook in a different file format to allow them 

to open and edit it in whatever spreadsheet software they have. 

Save A Workbook As A Template 
If you select Template from the Save as type: box, the workbook will be saved as a 

template in the Office Templates folder. You can use the template to create new workbooks, 

containing the same data, formulas, and formatting as the original.  

Working With Functions 
Excel’s functions are built-in calculation tools that perform complex financial, statistical or 

analytical calculations, assist in decision-making and create or manipulate text. Although you 

can enter many of these functions manually as a formula, using built-in functions can help 

reduce errors.   

You worked with the =SUM function in a previous session when you added using Autosum and 

Paste Function. A function is a predefined formula designed to make life easier by doing a 

common or a complicated task. If there is no pre-defined functions available, you can enter a 

formula. 

 

FORMULA  FUNCTION 

=A1+A2+A3+A4    =SUM(A1:A7) 

=A8-A10     No function available, use the formula 

(A1+A2+A3+A4+A5)/5   =AVG(A1:A5) 

Function Format 

Each function consists of the equal (=) sign, the function name and the arguments. Arguments 

are cells used for carrying out of the calculation. The most common argument type is numeric, 

but arguments can also be text, values, dates, time or arrays. The general format of a function 

is: 

=FUNCTION-NAME(ARGUMENT1, ARGUMETNT2….) 

Note that spaces are not used and that a comma separates the arguments if there are more 

than one. The function name must be one of the pre-defined functions available in Excel, there 

are more than 200. 

Arguments are the specifications that tell Excel on which data it must perform the function. In 

the =SUM function, the argument was the range which was to be summed. 

Entering Functions 

In the active cell, type =, followed by the function name, followed by an open parenthesis. 

Then specify the cell or range of cells you want the function to use, followed by a closed 

parenthesis. Press Enter to display the result of the formula in the cell. See what happens to 

the Name box and the formula bar when you do this. 

=SUM(A1:D1) 
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Create a function by pointing 
 Click on the = on the formula bar 

 Select a function from the  Name box. 

Basic Mathematical Functions 

SUM 

Adds all the numbers in a range of cells. 

Syntax 

SUM(number1,number2, ...) 

Number1, number2, ...    are 1 to 30 arguments for which you want the total value or sum. 

Remarks 

 Numbers, logical values, and text representations of numbers that you type directly into 

the list of arguments are counted. See the first and second examples following.  

 If an argument is an array or reference, only numbers in that array or reference are 

counted. Empty cells, logical values, text, or error values in the array or reference are 

ignored. See the third example following.  

 Arguments that are error values or text that cannot be translated into numbers cause 

errors.  

ROUND 

Rounds a number to a specified number of digits. 

Syntax 

ROUND(number,num_digits) 

Number is the number you want to round. 

Num_digits specifies the number of digits to which you want to round number. 

Remarks 

 If num_digits is greater than 0 (zero), then number is rounded to the specified number 

of decimal places.  

 If num_digits is 0, then number is rounded to the nearest integer.  

 If num_digits is less than 0, then number is rounded to the left of the decimal point.  
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Example 

 

 

 

INT 

Rounds a number down to the nearest integer 

Syntax 

INT(number) 

Number is the real number you want to round down to an integer. 

Example 

 

Statistical Functions 
Statistical functions perform different counting operations on data. 

When using these functions, you should be aware of different types of empty values that a cell 

can hold: 

 Blank - blank cells contain no data at all. 

 Empty text - resulting from a formula that assigns a null text string ("") to a cell. 

 Zero - a cell storing the value 0 (zero).  

Different functions may treat either empty text or zero-value cells or both as blanks. 
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Use Counting Functions 

Variations on the COUNT function allow you to calculate the number of values used in a range. 

COUNT function 

COUNT (value1, value2, ...) returns the number of numbers supplied by the Value1, Value2... 

arguments. A "number" is a numeric value, a date or time, or text representing a number (for 

example, "two" is included in the result). Other text, logical values, errors, and blank cells are 

not included in the result. Arguments are typically cell ranges, but you can supply any type of 

value if necessary. You can include up to 30 arguments. 

In the example below, in cells F3 and G3, the COUNT function is being used to count valid 

values in D3:D10 and E3:E10 respectively (=COUNT(D3:D10)). Note that zero values (E7 and 

E9) are counted, but text (D7) and blanks (D10) are not. 

 

 

 

Tip  COUNT is equivalent to PURECOUNT in Lotus 1-2-3. 

 

COUNTA function 

COUNTA (value 1, value 2, ...) works like COUNT, but includes any type of value (including 

text and error messages) in the result. The only values not counted are blank cells. 

In the example below, COUNTA is being used in place of COUNT. Cell D7 is now being counted 

as a value even though it is a text value. D10 is still excluded because it is blank. 

 

 

 



 Page 42 

 

COUNTIF function 

COUNTIF (range, criteria) counts the number of values within the range that meet the 

given criteria. Criteria can be a number, text, or expression. 

 

 
 

In the example, in cell F3 the COUNTIF function counts the number of cells in the range 

B3:B9 that contain the text "A"  (=COUNT(B3:B9,"A")). 

Use Averaging Functions 

AVERAGE and AVERAGEA functions 

AVERAGE (value 1, value 2, ...) returns the average (or mean) value. It can take up to 30 

arguments. If an argument is non-numeric, the value is ignored and does not affect the result.  

AVERAGEA is the same, except that it treats text and blank cells as zero. True values are 

equivalent to 1; false values to zero. 

 

 
AVERAGE compared with AVERAGEA 

 

In the example above, the text value "Code?" is ignored by AVERAGE but treated as zero by 

AVERAGEA, explaining the difference in results. 
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Use Other Statistical Functions 

Except for LARGE, the following functions all take up to 30 arguments. 

 

Functions Notes 

MIN 

MINA 

Returns the smallest value from its arguments. MINA treats text, 

blanks, and FALSE values as zero; TRUE values as 1. MIN ignores 

non-numeric values. 

MAX 

MAXA 

Returns the largest value from its arguments. MAXA treats text, 

blanks, and FALSE values as zero; TRUE values as 1. MAX ignores 

non-numeric values. 

LARGE(range, n) Returns the n-th largest value in the range (where n = 1, the 

largest value is returned). #NUM error is returned if n is greater 

than the number of values in the range. 

MEDIAN Returns the value in the middle of its arguments. 

MODE Returns the most frequently occurring value from its arguments. 

STDEV 

STDEVA 

Estimates the standard deviation (that is, a value measuring how 

far values in the sample are spread from the average (mean) 

value). The lower the standard deviation, the less spread out the 

values in the sample are. Standard deviation is used to compare 

sets of data. 

 

Exercise 30 

 Open the workbook GRADES 

 (1) Create a formula in A2 to calculate the number of A grades achieved by students 

(range D33:AC152), using relative or absolute references so that you can fill the 

formula across to G2 accurately 

 (2) In B3, create a formula to show what percentage of the total passes at that grade 

represent, then fill the formula across to G2 

 (3) In A4, create a formula to count the number of A passes, using an IF formula to 

insert a zero-length string ("") if the result is 0 

 Copy the formula in A4 down to row 29 then use Find and Replace to adjust the column 

reference in each cell 

 Copy the formulas in B4:B29 to column G, making sure that the absolute/relative cell 

referencing you have used produces correct results (alternatively, you could use named 

ranges or labels if you know how) 

 (4) Assuming A=10pts, B=8pts, C=6pts, D=4pts, and E=2pts, create a formula and fill 

down B33:A152 to calculate the number of points scored by each student 

 (5) Create a formula in I1 to calculate the number of students 

 (6) Create formulas in I2 and I3 to calculate what percentage of total entrants achieved 

passes graded from A-C and A-E 
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 (7) Create a formula to work out the average number of passes at grades A-C for any 

given subject  - do not treat empty cells as zero values 

 (8) Create formulas in I5 and I6 to show the highest and lowest student points totals 

 Save and close the workbook 

 



 Page 45 

 

SOLVE A BUSINESS PROBLEM 
 

Specific Outcome 

Use a computer spreadsheet file to solve a business problem 

 

 

Assessment criteria 

 Cell ranges within the spreadsheet are charted to meet user requirements 

 The problem is solved by the spreadsheet created 

 What if" exercises are applied to the spreadsheet in order to accommodate changes in 

requirements 

 Where available, the use of the onscreen help facility is demonstrated 

 File management techniques are demonstrated in terms of creating, naming, saving, 

copying, renaming, deleting, locating directory (folder), displaying directory contents 

printing and relocating 

 The file is previewed and printed using page setup appropriate to the layout: Showing 

gridlines, setting printing range, shrinking to one page, alignment. Headers and footers 
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Create And Edit A Graph/Chart 

Chart Types 

When planning a chart, one of the main decisions to make is to choose the chart type. There 

are fourteen main types to choose from in Excel. The following are the most commonly used 

types:  

 

Bar chart to compare values 

Column or Line to compare values often over a period of time 

Area to compare values over time and show how the total value breaks down 

Pie to show how a total breaks down 

 

Uses of charts 

Bar Chart Compares measurements at intervals, the bars run horizontally 

Column Chart Compares measurements at intervals and provide a view of data at a 

specific time - a snapshot. Column charts are available in 2-D and 3-D 

format. The bars run vertically. They are stacked and 100% stacked types 

are available. 

Line Charts Show the changes in data or trends over a given period of time. They are 

used to emphasize rather than compare. 

Pie Charts Show the breakdown of a total. The pie can be exploded into slices to 

emphasize certain data. 

XY (Scattered Charts) Show a degree of correspondence between two series of numbers. 

These are scientific charts. 

Area Charts Show the amount of change in a set of values over a specific interval of 

time. They are similar to line charts but are used to emphasize the rate of 

change rather than the amount of change 

Doughnut Charts Display several series of data in successive rings, as opposed to a Pie 

Chart that will only display single data series 

Radar Charts Display the best and worst combinations of values. Colours and patterns 

are used to designate areas with the same value. 

Bubble Charts Are used in the same way as an XY Scatter chart, only displaying bubbles 

of different sizes at the data points to indicate the value of a third 

number.  

Plotting a chart 

Data for a chart has to be laid out in a table with column and row headings, but you do not 

have to select all the data. Bar, column and line charts are made up of: 

 The data series (the values that are plotted),  

 The value axis (displaying the range of values in the data series)  
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 And the category axis (displaying the range of items providing the values) 

Create a chart 
 You can create either an embedded chart or a chart sheet.  

 Select the cells that contain the data that you want to appear in the chart.  

 If you want the column and row labels to appear in the chart, include the cells that 

contain them in the selection.  

 Click Chart Wizard  

 Follow the instructions in the Chart Wizard.  

Create a chart from nonadjacent selections 

 Select the first group of cells that contain the data you want to include. 

 While holding down CTRL, select any additional cell groups you want to include.  

 The nonadjacent selections must form a rectangle.  

 Click Chart Wizard  

 Follow the instructions in the Chart Wizard.  

Create a chart in one step 

 To create a chart sheet that uses the default chart type, select the data you want to 

plot, and then press F11. 

 To create an embedded chart that uses the default chart type, select the data you want 

to plot, and then click Default Chart If the Default Chart button is not available, 

add it to a toolbar.  

 When you create a chart using this quick procedure, the default chart type for Microsoft 

Excel is used. The default chart type is a column chart, unless you have changed it. 

 

Edit Chart Elements 

The individual chart elements can also be selected and customised, for example the font, scale, 

colour and size. 

Change chart labels, titles, and other text 

Most chart text — such as category axis labels, data series names, legend text, and data labels 

— is linked to the cells on the worksheet used to create the chart. If you edit the text of these 

items on the chart, they are no longer linked to the worksheet cells. To change the text of 

these items and maintain links to worksheet cells, edit the text on the worksheet. 

 To change legend text or data series names on the worksheet, click the cell that 

contains the data series name you want to change, type the new name, and then press 

ENTER. 

 To change legend text or data series names on the chart, click the chart, and then click 

Source Data on the Chart menu. On the Series tab, click the data series names you 
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want to change. In the Name box, specify the worksheet cell you want to use as the 

legend text or data series name. You can also type the name you want to use.  

 If you type a name in the Name box, the legend text or data series name is no longer 

linked to a worksheet cell.  

 To change data labels on the worksheet, click the cell that contains the information you 

want to change, type the new text or value, and then press ENTER.  

 To change data labels on the chart, click once on the data label you want to change to 

select the data labels for the entire series, and then click again to select the individual 

data label. Type the new text or value, and then press ENTER.  

 If you change the data label text on the chart, it is no longer linked to a worksheet cell.  

 To change category axis labels on the worksheet, click the cell that contains the label 

name you want to change, type the new name, and then press ENTER. 

 To change category axis labels on the chart, click the chart, and then click Source Data 

on the Chart menu. In the Category axis labels box on the Series tab, specify the 

worksheet range you want to use as category axis labels. You can also type the labels 

you want to use, separated by commas, for example: Division A, Division B, Division C  

 If you type the label text in the Category axis labels box, the category axis text is no 

longer linked to a worksheet cell.  

Ways to select chart items 
 To select a chart item by using the mouse, do one of two things:  

 Click the chart item you want. Data series, data labels, and the legend have individual 

elements that can be selected after you select the group. For example, to select a single 

data marker in a data series, click the data series, and then click the data marker. 

Microsoft Excel displays the name of a chart item in a tip when you rest the pointer over 

the item if you have the Show names check box selected (Tools menu, Options 

command, Chart tab). 

 Click the chart, click the arrow next to the Chart Objects box on the Chart toolbar, 

and then click the item you want 

Edit chart and axis titles 
 Click the title you want to change. 

 Type the new text you want. 

 Press ENTER.  

Select a different chart type 

For most 2-D charts, you can change the chart type of either a data series or the entire chart. 

For bubble charts, you can change only the type of the entire chart. For most 3-D charts, 

changing the chart type affects the entire chart. For 3-D bar and column charts, you can 

change a data series to the cone, cylinder, or pyramid chart type.  

 Do one of the following:  

 To change the chart type of the entire chart, click the chart.  

 To change the chart type of a data series, click the data series.  

 On the Chart menu, click Chart Type. 

 On the Standard Types or Custom Types tab, click the chart type you want.  

 To apply the cone, cylinder, or pyramid chart type to a 3-D bar or column data series, 

click Cylinder, Cone, or Pyramid in the Chart type box on the Standard Types 

tab, and then select the Apply to selection check box.  
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Default Charts 

The default chart type for Microsoft Excel is a column chart, unless you are creating a 

PivotChart report, in which case the default chart type is a stacked column chart. If you 

routinely create a different type of chart, such as a line chart, you can change the default chart 

type. If you already have a chart that has the chart type, items, and formatting you want, you 

can use that chart as the default chart type. 

Change the default chart type 

 To activate the Chart menu, click a chart.  

 On the Chart menu, click Chart Type. 

 On the Standard Types or Custom Types tab, click the chart type you want.  

 The Custom Types tab lists the current default chart, the built-in custom chart types, 

and any custom chart types you've added. You can create a chart with the chart type, 

items, and formatting you want and then save it as a custom chart type.  

 Click Set As Default Chart, and then click Yes. 

 To close the dialog box without changing the chart type of the current chart, click 

Cancel.  

 To close the dialog box and change the chart type of the current chart, click OK.  

Use the selected chart as the default chart type 

 Click the chart you want to use as the default chart type.  

 On the Chart menu, click Chart Type. 

 On the Custom Types tab, click Set As Default Chart, and then click Yes. 

 If the Add Custom Chart Type dialog box appears, type a name in the Name box, 

type a description in the Description box, and then click OK.  

Format a chart 

In Office, you can use either Excel or the add-in application Microsoft Graph to create charts. 

Both types of chart can be inserted in a file as an object. The tools used to modify and format 

charts using the Excel chart editor or the Graph chart editor are very similar. 

Formatting a chart allows you to make data series more distinctive, add extra information 

(such as data values and labels), or simplify a chart by removing unnecessary elements. 

 

Note In the following topics, all references to the Chart 

toolbar can be taken to apply to the Standard Graph 

toolbar as well. 

Add or Remove Chart Elements 

Aside from the graph itself, most charts contain additional elements that make the chart easier 

to read and interpret. 
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Chart Elements 

Some of the more common elements of a basic chart are listed in the table below: 

 

 

 
Example chart elements 

 

To select a chart element 

 Click the chart element you want to select 

OR 

 On the Chart toolbar, click the arrow on the 

Chart Objects box and select the object from the 

list 

Black selection handles are shown around the object. 

 
Chart Objects button 

 

Element Use 

Chart Area A collection of all the individual elements making up the chart (the 

chart "background"). 

Plot Area The series, axes, and labels. The plot area is useful for moving or 

resizing the "data" area of the chart. 

Legend, Titles, and Labels Resize, reposition, and format the legend, titles, and labels.  

Series and Values Format the values making up the chart data. 

Walls, Floor, Corners, and 

Gridlines 

Format the area directly behind the plotted values. 

Labels 

Chart 
Area 

Plot Area 

Walls and 
gridlines 

Legend 

Titles 
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Tip To select individual data points in a data series, click 

the series once then click the data point. 

To resize a chart element 

 You can click-and-drag on the handles of any of the chart elements to resize or modify 

them 

For example, dragging the corner handles of a 3D chart changes the perspective. 

To delete a chart element 

 Most chart elements can be removed by selecting them and pressing Delete  

To add or remove titles 

The range of options available for a chart depends on the chart type. Typically, you can add 

titles and labels to identify the chart, axes, data series, and data points. You can also choose 

whether to show or hide gridlines. 

 Open the chart object or select the chart sheet 

 From the Chart menu, select Chart Options... 

The Chart Options dialogue box is displayed. 

 Click the Titles tab 

 
Chart Options - Titles dialogue box 

 In the Chart title: box, type a chart title 

 If you want, in the Category (X) axis: box, type a title for the X (horizontal) axis 

 If you want, in the Value (Z) axis: box, type a title for the Z (vertical) axis 

 

Note To remove a title, delete the text in the box. 

 

To add data labels 

Data labels mark the exact value or percentage represented by a data point. Data labels are 

often used in bar or column charts to pinpoint values when data points are close together. 

Data labels are also commonly used in pie charts to identify the exact percentage represented 

by each pie slice. 



 Page 52 

 Click once on the chart object or chart sheet 

 From the Chart menu, select Chart Options... then click the Data Labels tab 

 

 
Chart Options - Data Labels dialogue box 

 De-select the check boxes to remove any data labels 

 Click Value to display a value next to each data point 

 Click Series name  or Category name to display the category label next to the data 

point  

 Click OK 

 

Tip Use the Data Table tab to show the chart's source data. 

 

To add, remove, and change the position of a legend 

A legend uses colour-coded boxes to identify the data series in a chart. If the North data series 

is represented in a bar chart by blue bars, for example, the legend shows a small blue box 

next to North.  

 Click once on the chart object or chart sheet 

 From the Chart menu, select Chart Options... then click the Legend tab 

The Legend tab in the Chart Options dialogue box is displayed. 
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Chart Options - Legend dialogue box 

 

 To show or hide the legend, check or uncheck the Show legend box 

 From the Placement options select a new position for the legend 

 Click OK 

To show or hide axes and gridlines 

If a chart shows data labels, you might prefer to hide one or both axes. Gridlines help to 

compare data, but you may prefer to get a "cleaner" look by hiding them. 

 Click once on the chart object or chart sheet 

 From the Chart menu, select Chart Options... then click the Axes tab 

 Check or clear the Category (X) axis and/or Value (Y) axis boxes to show or hide the 

horizontal and/or vertical axis respectively 

 

 
Chart Options - Axes dialogue box 

 Click the Gridlines tab 

Major gridlines mark out the values shown on the axes. Minor gridlines mark out values 

between the major gridlines. 
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Chart Options - Gridlines dialogue box 

 Select or de-select check boxes for the gridlines you want to show or hide 

 Click OK 

 

Tip The range of values used for gridlines is determined 

automatically. You can adjust it by formatting the chart 

axis (see below). 

 

Modify the Formatting of a Chart 

For each chart type, the individual elements of the chart can be selected and customised, for 

example, the font, scale, colour, and size. 

Basic font, fill, and line changes can be made using the Formatting toolbar. Alternatively, 

you can use the Format Chart Object dialogue box. 

 

Tip If the chart will be printed in black-and-white/greyscale, 

you should consider whether different colours used in a 

chart will be distinctive enough when printed. If 
producing a chart for greyscale printing, consider using 
fill pattern effects or grey fills and different 

line/borders. If you do use colours, make sure that they 

contrast strongly. 

 

To edit chart elements using the Chart/Graph toolbar 

The Standard Graph toolbar (used to edit a Graph object) contains different buttons than 

the Chart toolbar (used in Excel). 

Click To Click To 

 

Chart Objects 

Select an element of 
the chart to format.  

Import File 

(Graph Only) Import data into 
the datasheet from another file. 
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Format Chart Objects 

Display a dialogue 

box to format the 
selected chart object. 

 

View Datasheet 

(Graph Only) Display the 

datasheet window, allowing you 
to add or edit data. 

 

Chart Type 

Select a different 
chart type.  

Category Axis 
Gridlines 

(Graph Only) Show or hide major 
gridlines for the category axis. 

 

Legend 

Show or hide the 

chart legend.  

Value Axis 
Gridlines 

(Graph Only) Show or hide major 

gridlines for the value axis. 

 

Data Table 

Show or hide a table 
of the chart data 

below the chart. 

 

Angle Clockwise 

Slope the selected text down. 

 

By Row 

Plot the data series 
by row (the series 
label would normally 
come from the first 
value in the row). 

 

Angle 

Counterclockwise 

Slope the selected text up. 

 

By Column 

Plot the data series 
by column (the series 
label would normally 

come from the first 
value in the column). 

  

 

To change the formatting of a chart element 

You can apply different line and shading colours to the most elements of a chart and change 

the colour of text. You can also apply different value formats to chart data. 

 Select the chart element (by clicking on it or by selecting it from the Chart toolbar) 

 On the Chart toolbar, click Format Chart Objects  

OR 

 From the Format menu, select Selected Element... (SpeedKey: Ctrl + 1 ) 

The Format ChartElement dialogue box is displayed. 
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Format dialogue box - Patterns tab 

The Format dialogue box will have different tabs depending on which element is selected. 

 Click the Patterns tab to change the line (border) and fill (area) colours and styles 

 If the element has text associated with it, you can adjust the font and colour using the 

Font tab 

 

 
Format dialogue box - Font tab 

 Select the font formatting that you want to apply 
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 Set font colour and shading by choosing options from the Color: and Background: list 
boxes 

 Optionally, to scale text automatically if you resize the chart, check the Auto scale box 

 Click OK 

 

Tip If an element comprises of values of a specific data type, 

use the Number tab to adjust value formatting (for 
example, to display decimals, currency symbols, 

date/time formats, and so on). 

 

To change font and line/fill formatting of chart elements using 
the Formatting toolbar 

 Select the chart element to be formatted 

 On the Formatting toolbar, select the formatting option required 

 

 

 

Formatting toolbar (Excel) 

 

Font Font Size Italic Align Currency Highlight Font 
Color 

Show 
Buttons 

Bold Underline Merge and Center Percent Indent Borders 

Comma 

Increase 
Decimal 

Decrease 
Decimal 
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Format a Chart Axis 

With an axis, you can adjust font (including text alignment) and line formatting and adjust the 

range of values shown (scale).  

To change the formatting of values on an axis 

 To format labels on an axis, double-click on the axis 

The Format Axis dialogue box is displayed. 

 Select the Number tab 

 

 
Format Axis dialogue box 

 Set options as you would for a normal cell value format 

OR 

 Check the Linked to source box to use the value formatting used in the source cell(s) 

 Once you have chosen the format you want to use, click OK 

To modify the scale and display units of an axis 

In some circumstances, the scale of the value axis that is determined automatically may not 

be appropriate. For example, if a chart contains many low values and one very high value, you 

may want to cut off the high value in order to show the spread of low values in more detail. 

If the axes of your chart consist of large number values, you can make the axis text shorter 

and more readable by changing how the units are displayed on the axis. For example, if the 

chart values range from 1,000 to 5,000, you can display the numbers as 1 to 50 on the axis 

and show a label that indicates that the units express thousands. 

 

 Select the chart axis that you want to change 

 From the Format menu, select Selected Axis... and click the Scale tab 

The Format Axis dialogue box is displayed. 
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 Click the down arrow to the right of the Display units: box and select the appropriate 

option 

 Select the Show display units label on chart check box 

The Minimum: and Maximum: boxes allow you to enter the lowest and highest values you 

want to be displayed on the chart. Optionally, you can change the size of the units (which 

affect how gridlines are displayed). 

 Set the values you want 

 Click OK 

 

 
Original settings, producing the chart below... 

 
New scale and maximum value produce this chart... 

 

 
Original chart 

 
Chart with new settings applied 

To modify the line width of chart axes 

 Select the axis to format then on the Chart toolbar, click Format Axis (SpeedKey: 

Ctrl + 1 ) 

The Format Axis dialogue box is displayed. 

 Click the Patterns tab 

 Format Axis - Patterns dialogue box In the Lines panel, click the Custom option 

then select options from the Style:, Color: and Weight: (line width) list boxes 

 Click OK 
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Format a Data Series 

When formatting data series, you need to make sure that each series is distinctive and 

consistent. If you are printing in black-and-white, consider using fill patterns as well as colours 

to identify each series. 

You can apply different formatting to individual points within a data series (for example if you 

want to highlight a particularly high value) but in most cases, you should keep points within 

each series consistent. 

To change the series order 

In Excel (not Graph), you can modify the order in which data series are displayed. 

 Select a Series element (by clicking on it or by selecting it from the Chart toolbar) 

 On the Chart toolbar, click Format Chart Objects  

OR 

 From the Format menu, select Selected Data Series... (SpeedKey: Ctrl + 1 ) 

The Format dialogue box is displayed. The Format dialogue box will have different tabs 

depending on which element is selected. You can usually change things like the border or 

background colours, line colours and styles, font formatting and so on. 

 Click the Series Order tab 
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Format Data Series dialogue box - Series Order tab 

 Use the Move Up and Move Down buttons to change the series order  

 Click OK 

To widen the gap between columns/bars 

In a 2-D bar or column chart, you can change the overlap (or the amount of space between 

data series). You can also change the gap width (the distance between columns in different 

categories). 

In a 3-D chart, you cannot change the overlap, but you can change settings for the gap 
depth (the amount by which the columns are offset from the floor) and the chart depth 
(the degree of perspective shown on columns). 

You only need to select a single data series to re-format the whole chart. 

 Click once on the data series in the chart you want to change 

This selects all of the columns in the series. 

 From the Format menu, select Selected Data Series... 

The Format Data Series dialogue box is displayed. 

 Click the Options tab 
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Format Data Series - Options tab 

 In the Overlap: box, enter a value between -100 and 100 

The higher the value, the greater the overlap. Using a negative value inserts spaces between 

the columns within a category.  

OR 

 To change the amount of space between each category, in the Gap width: box enter 

a value of between 0 and 500 

The higher the value, the greater the amount of space between each category. 

 Click OK 

 

 
Overlap of 50 and Gap width of 25 

To change format data markers 

Bar, column, area, and pie charts have data markers that can be formatted with different 

border and fill colours and effects. 

On a line chart, you can change the colour and style of the line and the shape and colour 

used for data markers (each value point on the line). 
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 Select the data series you want to change 

 From the Format menu, select Selected Data Series... then click the Patterns tab 

  
Format Data Series - Patterns for bar and line charts 

 

 Select options for the marker's border/line and fill colour 

 Click OK  

To apply a fill effect to a data series 

Fill effects can add interest to a chart, especially in column and pie charts. Using pictures can 

help to make a chart more meaningful. For example, you could use product pictures to 

illustrate sales of different products. Using a pattern fill effect can help to contrast series if the 

chart is printed in black-and-white. 

As with drawing objects, you can format markers with gradient, texture, pattern, and picture 

fill effects. 

 

 
Charts with Gradient Effect 

 
Chart with 

Texture Effect 

 
Chart with Picture Effect 

 Select the data series you want to change 

 From the Format menu, select Selected Data Series... then click the Patterns tab 

 Click the Fill Effects... button 

The Fill Effects dialogue box is displayed. 

 Select the tabbed heading for the type effect you want to apply 
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Gradient and Pattern tabs in the Fill Effects dialogue box 

 

 Select from the effect options then click OK 

 

Tip On a 3-D chart, you can use the Shape tab to change the 

shape of the markers used for each series. For example, 

one series could be a cylinder and another a pyramid. 

To change the formatting of a single data point within a data 
series 

 Select the data series you want to change the colour of by clicking on any of the 

columns in the series once 

 Now click once on the data point in the data series that you want to change 

This now selects the single data point within the data series 

 From the Format menu, select Selected Data Point... 

The Format Data Point dialogue box is displayed. 

 Select options for the marker's border/line and fill colour and/or fill effects 

 Click OK 
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Create an XY (Scatter) Chart 

An XY (Scatter) chart has two value axes. Unlike other charts, markers are positioned on the 

chart according to value only - they are not organised into categories. 

Data for a scatter chart is normally laid out in 

a two-column table. The first column or row in 

the table contains X values (horizontal axis); 

the second column or row contains Y values 

(vertical axis). 

In the example, Distance from Sun provides 

values for the X axis; Temperature provides 

values for the Y axis. You can see that, with 

the exception of Venus, temperatures are 

lower the farther a planet is from the sun. 

 
Source data for chart 

 
Scatter graph with smoothed line 

Note A scatter chart with a line drawn on it may look like a 

line chart but the underlying data is very differently 
organised. A line chart displays data at regular intervals, 

using categories on the Y axis. A scatter chart is used to 
display clusters of data (where lots of values may occur 

at the same point in the chart). A line chart cannot do 

this. 

 

A scatter graph is not always drawn with a line to connect the points -  an important use of 

scatter graphs is to show the distribution of values rather than to compare data sets. 

A variation on a scatter graph is the bubble chart. A bubble chart shows a third value, 

indicated by the size of the data point (the bubble). In the following example, each planet's 

diameter has been represented on the bubble chart. 
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Source data for bubble chart 

 

 

 
3-D bubble chart 

To create an XY (Scatter) or bubble chart in Excel 
 Arrange the data that you want to chart into two columns (scatter chart) or three 

columns (bubble chart) 

 The column on the left should contain X-axis values. Alternatively, you can arrange data 

in two rows, with the top row containing X-axis values. 

 Select the data in the columns 

 On the Standard toolbar, click Chart Wizard  

OR 

 From the Insert menu, select Chart... 

 The Chart Wizard Step 1 dialogue box is displayed. 
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Scatter and bubble-type charts 

 

 From the Chart type: list, select XY (Scatter) or Bubble 

 From the Chart Sub-type: box, select a chart style 

 For scatter charts, you can chart with or without lines and with or without markers. You 

can choose between smoothed lines or straight lines. For a bubble chart, you can 

choose whether to use a 3-D effect or not. 

 Click the Press and Hold to View Sample button to see how the selected data will 

appear as a chart 

 Click Next > and complete the Chart Wizard as normal 

To create an XY scatter graph using Microsoft Graph 
 Insert a new graph object then clear any existing data from the datasheet 

 From the Chart menu, select Chart Type... 

 Select the ZY (Scatter) type and an appropriate sub-type then click OK 

 On the Graph toolbar, click By Columns  or By Rows  as appropriate 

 

 
Entering data for an XY (Scatter) graph by column 
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 Add the data you want to use to the datasheet, using the first column or row for X 

values 

 

Tip If the first row or column does not contain values for the 

X axis, click the row or column that does then from the 

Data menu, select Plot on X Axis. 

 

 
XY (Scatter) Graph object 

Add a Trendline to a Chart 

A trendline can be used to predict future values or to show the trend in actual values more 

clearly by averaging out very high or low points. 

Trendlines are commonly used with scatter graphs to show the trend in the data clearly. 

For the line to show an accurate prediction or trend, you must select the best type of trendline 

for the pattern of the data you are plotting. Six trendline types are available to show different 

patterns.  

Trendline Use To 

Linear Use to extrapolate values that increase or decrease at a steady rate (in a 

straight line). 

Logarithmic Use for values that increase or decrease quickly before levelling out. 

Polynomial Use for values that fluctuate. Depending on the range of data, a polynomial 

trendline will have one or more bends. 

Power Use for values that increase or decrease at a specific rate. 

Exponential Use for values that increase or decrease at increasingly higher rates. 
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Moving 

Average 

Smooth out fluctuations in data (average out high and low points). 

 

Tip Excel can calculate the reliability of a trendline. The R-

Squared value is a value from 0 to 1. The closer to 1 the 
R-Squared value is, the more reliable the trendline. You 

can display the R-Squared value on the chart. 

 

To add a trendline to a chart 

Select the chart 

From the Chart menu, select Add Trendline... 

OR 

 Right-click a data series and select Add Trendline... 

 The Add Trendline dialogue box is displayed. 

 In the Based on series box, select a series to calculate from 

 In the Trend/Regression type panel, select the trendline to use 

 

Add Trendline dialogue box - Type tab 

 

Note For Polynomial lines, set the Order (this is related to the 

number of bends in the curve - Order 2 has one bend, 3 

has two and so on). For a Moving Average, set the Period 
(the number of values to average into a point on the 

trendline). 

 

 Click the Options tab 
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Add Trendline dialogue box - Options tab 

 

The default legend shows the type of trendline and the name of the data series.  

 To change the legend, click the Custom option button and enter a label 

 To extrapolate the trendline beyond the values used in the chart, enter a number of 

periods (Forward and/or Backward) in the Forecast panel 

 Optionally, select the check boxes to Display equation (used to calculate the 

trendline) or the R-squared value (the reliability of the trendline) 

 Click OK 

 

 
Example of trendline 

Notice that the trendline does not connect with all the data points on the chart (the only 

instance when the line would connect with all data points is where R2=1). 
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Tip You can add more than one trendline to a chart. You can 

also add multiple trendlines for the same data series. 

To change options for a trendline 

You can apply formatting and change the options used for a trendline as you can for any other 

chart element. 

 Select the trendline then from the Format menu, select Selected Trendline...  

(SpeedKey: Ctrl + 1 ) 

OR 

 Right-click the trendline then select Format Trendline... 

To remove a trendline 

 Select the trendline then from the Edit menu, select Clear then Trendline  

(SpeedKey: Delete ) 

Create a Combination Chart 

A combination chart displays different and possibly incompatible types of data on the same 

chart (for example, combining Staffing Levels with Gross Turnover, or Production Volumes with 

Overhead Costs). Different data series can be displayed in different styles (for example, 

column and line), and possibly with a different scale for the axes.  

The combination chart type can be selected when creating the chart or an existing chart can 

be adapted by adding an extra series and converting it to combination style. A common 

combination is to plot one series with bars and the other with a line. 

To create a new combination chart in Excel 

 Select a data range for the chart 

 

 
Selecting a range to compare order values in 2003 with 2002 

 

 On the Standard toolbar, click the Chart Wizard button  

 The Chart Wizard dialogue box is displayed. 
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 Select the Custom Types tab 

 

 
Chart Wizard dialogue box - Custom Types tab 

 

 From the Chart Type: list, select a suitable combination chart 

 Continue with the remaining Chart Wizard steps 

 

 
Line-Column combination chart 
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To convert an existing chart to a combination chart in Excel 
or Graph 

On the chart, click once on the data series to be converted 

 

  
Selecting the "Number of Orders" data series to convert to a different chart type 

 

 From the Chart menu, select Chart Type... 

 The Chart Type dialogue box is displayed. 

 From the Chart Type list, select a suitable chart style 

 Click OK 

 

 
Selected series plotted as a line chart 
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Optionally, you can add a secondary axis for the series. If the range of values is very different 

from the primary Y axis, you must do this or the second series will not be visible (as above). In 

the example above, order numbers are counted in a range from 0 to 800, whereas order value 

ranges from 0 to 300000. 

 On the chart select the same data series again 

 From the Format menu, select Selected Data Series... (SpeedKey: Ctrl + 1 ) 

 The Format Data Series dialogue box is displayed. 

 

 
Format Data Series dialogue box - Axis tab 

 

 Select the Axis tab 

 In the Plot series on panel, select the Secondary axis option button 

 Click OK 

 

Exercise 31 

 Open the workbook ANNUAL RESULTS 

 

Tip This exercise will be easiest to complete in Excel. If you 

prefer to practise using a Graph object in Word or 
PowerPoint, the same data is available in the document 

and presentation files named ANNUAL RESULTS. 
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 Select from B2:C41 then from the Insert menu, select Chart... 

 The Chart Wizard Step 1 dialogue box is displayed. 

 From the Chart type: list, select XY (Scatter) 

 From the Chart Sub-type: box, select Scatter 

 Click the Press and Hold to View Sample button to see how the selected data will 

appear as a chart 

 Click Next > 

 Click the Series tab and type Orders in the Name: box 

 Click Next > 

 In the Chart Options dialogue box, change the Chart title: to Order Values by 

Quantity and hide the legend 

 Click Next > 

 Create the chart as a new sheet named ValueByQuantity 

 When the chart is created, point to some of the data markers to see the value 

Notice that values do not appear in the same order as in the worksheet. The first value plotted 

is the month with the lowest number of orders. The greater the number of orders, the further 

to the right the marker is positioned; the greater the value, the further up the chart the 

marker is. 

 From the Chart menu, select Add Trendline... 

 In the Trend/Regression type panel, select Linear 

 Click the Options tab and check the R-squared value box 

 Click OK 

You should be able to see that the number of orders is quite a good predictor of the value of 

sales. 

 Save and close the workbook 

 Open the workbook TRENDLINES 

 

Tip This exercise will be easiest to complete in Excel. If you 

prefer to practise using a Graph object in Word or 
PowerPoint, the same data is available in the document 
and presentation files named TRENDLINES. You will not 

be able to complete the steps where you change values 

on the chart. 

 

 Create a bar chart for the first three items on the sheet, but not the Overheads line 

 Add the Overheads line to the chart; set the series as a line chart 

 Click-and-drag one of the bars to change the bar value 

 Click-and-drag one of the points on the Overheads line to change the line value 
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Because the values for overheads are calculated by 

formulas, the Goal Seek dialogue box is displayed, 

prompting you to select a cell containing a value to 

change. 

 Select one of the cells in the same column as the 

data point (in the above example, select J2, J3 or 

J4) 

 
 

Goal Seek dialogue box 

 

 Create a second bar chart for the first three items on the sheet, but not the Overheads 

 Add trendlines to the different data series, experimenting with different types and 

extrapolating to predict future results 

 Reformat the chart appearance, and add it to the list of Custom chart templates with 

the name Trendy 

 Set Trendy as the default chart type 

 Create a third chart for the same data as above - Trendy should be the default chart 

 Delete the Trendy chart template 

 Save and close the file 

What If? 
What-If? analysis allows you to test how changes in certain variables affect the results of 

formulas in a worksheet. For example, you could enter values to discover at what sales would 

be required for a product to recoup its development costs, over a given period or test 

investment considerations with different rates of return or cash flows. You can also test 
calculations with extremely high or low values. 

Several tools are available to accomplish this: 

 Data Tables show a range of results obtained by varying one or two variables in a 

formula. 

 Goal Seeking is a way of solving a problem where you know the result you want to 

achieve but not a variable value required to achieve it. The Goal Seeker rapidly 

iterates different values until it finds one that permits the formula result. 

 The Solver operates on more complex goals by analysing all of the formulas associated 

with the required result. It can change several variables at once and test the result for 

each change until the required result is reached. Constraints or conditions can be 

created that place limits on what variables can be used, which may disclose that the 

desired result is in fact unobtainable. 

 Scenario Manager is a forecasting tool that generates a result based on given 

variables. The variables can be changed to project different eventualities and each set 

of variables stored as a scenario for review and comparison.  

Use a Data Table to Perform What-If? Analysis 

You can use a Data Table to analyse the effects of different variables (or inputs). 

To create a one-input data table 

A one-input data table allows you to test a formula with a range of values in one of the 

formula's inputs. For example, calculating the cost of a loan depends on the amount borrowed, 
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the interest rate, and the number of payments to make. A one-input data table could look at 

the effects of varying any one of these three variables. 

 Create the worksheet to solve the problem with the default values 

 Elsewhere on the same worksheet, create a table listing alternative values for the 

variable you want to test (for example, varying rates of interest) 

 This can be laid out as a column or as a row. In this example, a column of values has 

been entered in A8:A13. 

 In the top row of the data table in the column to the right of the input column (cell B7 

in the example), either reference the formula you want to use to obtain the answers or 

enter a formula directly into the cell  

 
 

The example uses =B4 in cell B7 because we want to know the effects on the formula we are 

using to calculate payments. 

 
Select the data table including the heading 

row 

Select the cells that are used in the data 

table including the heading row 

In our example, this is A7:B13. 

From the Data menu, select Table... 

The Table dialogue box is displayed. 

 

 
Table dialogue box 

 

 Enter either a Row input cell or a Column input cell by clicking on the relevant cell 
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 The input cell is the cell in the worksheet 

solution containing the variable to change. 

In our example, this is the Rate cell $B$2 

(entered as an absolute reference). Because 

the data table is laid out in a column, the 

input cell is entered into the Column input 
cell: box. If the data table were laid out in 

a row, the Row input cell: box would be 

used. 

 Click OK 

 The right-hand column of the data table fills 

with the payment figures for each rate of 

interest.  

  
The right-hand column fills with the 

payment figures 

You can alter the values in the left-hand column to see different results 

To create a two-input data table 

A two-input table shows different values for two variables. For example, you might want to 

analyse the payments required for different loan amounts at varying rates of interest. 

A two-input data table contains an additional row of values next to the formula to calculate. 

The formula or reference to the formula must be in the top left-hand corner of the table (cell 

B7 in the example below). 

 

 
Two-input data table 

 

 As for the one-input table, set up the worksheet to solve the problem 

 Create a reference to the formula to use (or the formula itself) in the top left-hand 

corner of the data table area 

 Add values for the first variable in the column below the formula reference 

 Add values for the second variable in the row to the right of the formula reference 

 Select the cells that are used in the table (in our example this would be from B9:H18) 

 From the Data menu, select Table... 

 The Table dialogue box is displayed. 
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Table dialogue box 

 

 Enter the Row input cell and the Column input cell 

 In the example, the row input is the Principal ($B$1) and the column input is the Rate 

($B$2). 

 Click OK 

 The data table fills with the payment figures based on the loan amount and the rate of 

interest.  

 

 
Resulting data table 

To modify a data table 

You can change the values of inputs to show different results, but to expand the table you 

must clear the existing results and re-create the table using the Table dialogue box. 

Use Goal Seek 
Goal Seek takes the time and guesswork out of repeatedly entering a variable value until a 

desired result is produced by a calculation. This function enters the value for you 

automatically, incrementing it until the desired result is achieved. For example, how much can 

you borrow if you can afford a monthly repayment of £150 for 3 years, with an interest rate of 

12.2% per annum? 

To solve a problem using Goal Seek 
 Enter a calculation using known values and or guesses 

 From the Tools menu, select Goal Seek… 

 The Goal Seek dialogue box is displayed. 
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 In the Set cell: box, select the cell containing the result formula 

 In the To value: box, enter the target result required 

 In the By changing cell: box, select the cell containing the variable to change 

 

 
Goal Seek example 

 Click OK 

 The Goal Seek Status message box is displayed with the nearest obtainable result if it 

can be achieved. 

 

 
Goal Seek Status example 

 Click OK 

Use Solver 
The Solver calculates complex problems using a number of conditions. It will produce an 

optimal solution, plus a series of sub-optimal solutions, or decree that there is no workable 

solution. The following information is required by Solver to provide a solution. 

 Target Cell 

The cell where Solver will place its result. It may be one of the changing cells, or a cell whose 

result depends upon a changing cell. The Target cell must contain a formula that can be 

calculated. 

 Changing Cells 

The cell(s) containing variable values that Solver will update with alternative data while it is 

trying to calculate the result in the target cell. 

 Constraints Cells 

Cells containing values used in conditions that must be met for a valid result. If the constraints 

are too limiting then no solution will be obtainable. 
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To find a solution using Solver 

In the following example, the line manager of the FlipFlap 24 hour pancake outlet has to assign 

shifts to his staff for the working week. The number of shifts required is totalled in B12. The 

question is, given that different members of staff are paid differently per shift, what is the 

cheapest way to fill the number of shifts required, assuming that members of staff will not 

work more than 7 shifts in a week? 

 

 
Solver example 

 

 Enter the data on the sheet 

 Create a formula in the Target cell that will calculate the result when the correct values 

are entered in the Changing cells (in the example, this is cell D11) 

 Enter a 0 (zero) or a best guess in the Changing cells (these are cells C2:C10) 

 Optionally, enter any constraints (this is the number of shifts required, entered in D12) 

 From the Tools menu, select Solver... 

 The Solver Parameters dialogue box is displayed. 

 In the Set Target Cell: box, select the target cell  

 Select an Equal to: option button for the method of achieving the target (in our 

example, this is Min - to find the cheapest cost) 

 If necessary, in the Value of: box, enter the value the target cell should finally display 

 In the By Changing Cells: box, select the cell(s) whose values must change to 

calculate the result (this is the range C2:C10) 

 Click the Add... button to add any constraints 

 

 
Add Constraint dialogue box 

 Click Add to add further constraints or click OK 



 Page 82 

 The Solver Parameters dialogue box is re-displayed. 

 

 
Solver Parameters dialogue box 

 

In this example, the constraints ensure that the changing cells are whole numbers greater 

than 0 but less than 7 and that the shifts worked are at least equal to the shifts required. 

 Click Solve 

 The Solver Results dialogue box is displayed. 

 

 
Solver example 

 

 Select either the Keep Solver Solution or the Restore Original Values option 

buttons 

 Click OK 

 The worksheet display is updated with the Solver Results. 

Tip  You can run the Solver several times using different 

target values and save each solution as a scenario. This 
allows you to review several different targets without 

recreating the Solver each time. 



 Page 83 

Use the Scenario Manager 
Scenario Manager is a forecasting tool that generates a result based on given variables. The 

variables can be changed to project different eventualities and each set of variables stored as a 

scenario for review and comparison.  

For example, you are considering buying an annuity that will pay you £5000 each year for the 

next 10 years plus a lump sum of £10,000 at the end of the annuity. The cost of the annuity is 

£40,000. The Present Value function is used to display the value of the annuity to you, but that 

value depends heavily on the rate of return you can expect on other ways of investing 

£40,000. 

At a 3% rate of return, the cost price of £40000 

looks exceptional value against the present value 

of the annuity (£50,091.05). But what would the 

cost look like if you thought you could obtain a 

better rate of return? Creating a scenario allows 

you to compare the effects of different rates. 

 
Example scenario layout 

To create a scenario  

Create a forecast spreadsheet with formula(s) that depend on one or more variables that can 

be changed 

Optionally, create range names for each of the variable cells 

 From the Tools menu, select Scenarios... 

 The Scenario Manager dialogue 

box is displayed. The Scenario 

Manager is blank until you add 

the first scenario. 

 Click Add... 

 The Add Scenario dialogue box is 

displayed. 

 In the Scenario name: box, enter 

a name that clearly identifies the 

intention of the scenario (Spaces 

are allowed) 

 In the Changing cells: box, select 

the cells containing the variable 

data 
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 In the Comment: box, add a fuller description of the purpose of the scenario 

 Click OK 

 The Scenario Values 
dialogue box is 

displayed. 

 In each of the variables 

cell boxes, enter a value 

to use for the named 

scenario 

 
Scenario Values dialogue box 

 

 To create further scenarios, click Add 

 

 To view the scenarios, click OK 

 The Scenario Manager dialogue box 

is displayed and the scenarios can be 

viewed. 

To view a scenario 
 In the Scenario Manager dialogue 

box, from the Scenarios: list, select a 

scenario to view then click Show 

 The scenario variables are entered on 

the worksheet and the result calculated. 

 Select and Show each scenario 

required 

 After viewing the scenarios click Close 

 
Scenario Manager dialogue box 

The last scenario viewed remains displayed on the screen. 

To delete a scenario 
 From the Scenarios list in the Scenario Manager dialogue box, select the scenario to 

delete 

 Click Delete 
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To edit a scenario 
 From the Scenarios list in the Scenario Manager dialogue box, select a scenario 

 Click Edit...  

 The Edit Scenario dialogue box is displayed. 

 Change the Scenario name: or 

Comment: 

 Click OK then change the value(s) 

as appropriate in the Scenario 
Values dialogue box 

 Click OK 

 

 
Edit Scenario dialogue box 

Create a Scenario Summary 

There are two types of scenario summary. A tabular view showing each set of scenario 

variables and the result produced, or a PivotTable view showing just the scenario names and 

the result of each scenario. 

To create a scenario summary 
 From the Tools menu, select Scenarios... 

 The Scenario Manager dialogue 

box is displayed. 

 Click Summary... 

 The Scenario Summary dialogue 

box is displayed. 

 From the Report type panel, select 

the summary option to create 

 
Scenario Summary dialogue box 
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 Click OK 

 A new Scenario sheet is created in the style selected. 

 

 
Scenario worksheet summary 

 
Scenario PivotTable summary 

 

 

Merge Scenarios 

Merging allows the scenario variables stored on another worksheet or workbook to be applied 

to the data in the current worksheet. The names or cell references of the variables must be the 

same in the current worksheet and the one being merged from, even if the data or the way it 

is laid out is different. 

To merge a scenario 
 Open the workbook(s) containing the scenarios to merge 

 From the Tools menu, select Scenarios... 

 Click Merge... 

 The Merge Scenarios 

dialogue box is 

displayed. 

 In the Book: box, select 

a workbook name 

 In the Sheet: box, select 

the worksheets 

containing the scenarios 

to merge 

 

 
Merge Scenarios dialogue box 

 Click OK 

 All of the scenarios on the source sheets are copied to the Scenario Manager in the 

active worksheet.  
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Exercise 32 

 Open the workbook FORECAST RESULTS 

 Click in cell B1 then name the cell target_growth 

 In C3:C15, enter a formula to calculate the target for 2004 (2003's result increased by 

target growth) 

 From the Tools menu, select  Scenarios... 

 Click Add... 

 Enter the Scenario name: of Low Growth 

 In Changing cells:, type target_growth 

 Click OK 

 Enter the value as 0.05 and click Add 

 Repeat to add Medium and High Growth scenarios of 0.01 and 0.02 respectively, 

clicking OK after you add a value for High Growth 

 From the Scenario Manager, select High Growth and click Show 

 Click Edit then change the value for High Growth to 0.15 

 Click the Summary button 

 For the Report type, select Scenario summary 

 For Result cells, select C15 

 Click OK 

 View the summary sheet 

 Save and close the workbook 

 

 Open the file SOLVER and select the Goal Seek sheet  

 Use Goal Seek to find the loan amount that can be borrowed over 60 months with a 

repayment of £200 

 Select the Solver sheet 

 Use the Solver to calculate the quotation for a Total Load of 2000 cubic metres 

 Change the Load capacity of the dumpers to see what effect bigger ones would have 

 Change other parameters (such as Trips per Day; Running Costs; Max Quotation; and 

Max Working Days) recalculating after each change 

 Save and close the workbook 

Open the file SCENARIOS 

 Create a data table below the existing worksheet data to show variable results for Year 
5 Profits (cell F15) with figures for Sales Growth (B6) ranging from 7-12% in 0.5% 

increments 

 Modify the data table to show a range of values for Sales Volume (B2) against Sales 

Growth, with Sales Volume values ranging from 50000 to 90000 in 5000 

increments 

 Print a copy of the worksheet 

 Delete the data table 

 Create scenarios for High, Low, and Medium growth, changing the values in cells B6, B7, 

and B8 

 View the scenarios then edit the scenario values 
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 Create a Scenario Summary sheet 

 Save and close the workbook 

File Management 

Add, delete, or move page breaks 
 On the View menu, click Page Break Preview. 

 Do one of the following: 

 View page breaks:  Manually inserted page breaks appear as solid lines. Dashed 

lines indicate where Microsoft Excel will break pages automatically. 

 Move a page break:  Drag the page break to a new location. Moving an automatic 

page break changes it to a manual page break. 

 Insert vertical or horizontal page breaks: Select a row or column below or to 

the right of where you want to insert a horizontal or vertical page break, right-click, 

and then click Insert Page Break. 

 Remove page breaks:  Drag the page break outside of the print area. To remove 

all manual page breaks, right-click any cell on the worksheet, and then click Reset All 

Page Breaks. 

Worksheets are usually too large to show all the data on one screen and having to scroll 

repeatedly  slow and makes comparing parts of the same sheet difficult. To overcome this, a 

large worksheet can be split into panes, where you can view two different parts of the 

worksheet at the same time and scroll the panes independently or open a new window for the 

workbook. 

Another tool allows you to freeze row and column titles so that they are always shown on-

screen. For example, if you are working with a data list, you could freeze row 1 so that the 

column labels are always shown. Finally, you can hide and unhide rows, columns, worksheets, 

and workbooks. Hiding data can be useful to make viewing a large sheet easier or to protect 

sensitive information.  

Go To a Cell 

You can use the Name box or the Go To tool to select named ranges on a worksheet. You 

can also use both these tools to move the active cell to a specific cell reference. 

Tip  Look up the topic "Name cells in a workbook" in the 

online help for more information about named ranges. 

 

To select a range using the Name box 
 Type the cell reference into the Name box 

OR 

Type the range name into the Name box 

OR 

 Click the arrow on the Name box 

and select a location from the pull-

down list 

 
Name box 
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The named cell(s) are selected on the sheet, exactly as they appeared when the name was 

created. 

To select a range using the 
Go To dialogue box 

 From the Edit menu, select Go 

To...(SpeedKey: F5  or Ctrl + G ) 

The Go To dialogue box is displayed 

showing a list of named locations in the 

workbook. 

 Select a name from the list or enter 

a grid reference in the Reference 

box 

 Click OK 

 

 
Go To dialogue box 

Split a Worksheet into Panes 

 

To make large sheets easier to work with, the window 

can be split into horizontal and vertical panes. Split 

boxes are positioned at the top of the vertical scroll bar 

and the right of the horizontal scroll bar. 

You can use the panes to view, edit, move, and copy 

data around the sheet more easily. 

To split the window into panes 
 Click-and-drag the horizontal or vertical split box to the required location on the sheet 

OR 

 Position the active cell where the splits are to be located then from the Window menu, 

select Split 

The screen is split into panes that can be scrolled independently. 

 Click the mouse in the pane to activate, or press F6  to activate each pane in sequence 

Split  
boxes 
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Example of worksheet panes 

 

To clear worksheet panes 
 Double-click on the split boxes, or click-and-drag them to the edge of the sheet OR 

from the Window menu, select Remove Split 

Freeze Row and Column Panes as Titles 

It is often useful to keep worksheet titles (entries in the first row or column that identify the 

data) on-screen all the time. To do this you can freeze panes as titles. Unlike normal panes, 

there are no scroll bars for the frozen area. 

To freeze panes as worksheet titles 
 Click on the cell where the freeze should be applied 

Any row(s) above and column(s) to the left of the active cell will be frozen. 

 From the Window menu, select Freeze Panes 

 

 
Example of freezing titles (at cell C8) 

Columns to the left and rows above the active cell are frozen. The frozen titles are indicated by 

black gridlines. 

To unfreeze worksheet titles 
 From the Window menu, select Unfreeze Panes 
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To convert between panes and freeze titles 

If you have applied panes to a worksheet, applying freeze panes will convert the panes to 

freeze titles. Similarly, if you have applied freeze panes, applying normal panes will convert 

the freeze titles to panes. 

View a Workbook in Two Windows 

As an alternative to splitting one window into panes, you can open another window for the 

active workbook and arrange both on-screen. This means that you can view different 

worksheets in the same workbook at the same time. 

To view the active workbook in multiple windows 
 From the Window menu, select New Window 

A new window is opened. The title bar shows the name of the workbook with :2 after it. The 

windows are still showing exactly the same file. Any changes you make in one window will be 

updated to the other. When more than one window is visible, select the workbook to work in 

by clicking on it with the mouse. The first click will activate the window but will not change the 

active cell. Alternatively, you can use Ctrl + Tab  to switch between windows or use the 

Window menu. You can also arrange the windows on-screen: 

 From the Window menu, select Arrange... 

The Arrange Windows dialogue box is displayed. 

 From the Arrange panel select an 

arrangement method 

 If you have other workbooks open, and 

only want to arrange the windows of the 

active workbook, check the Windows of 
active workbook box 

 Click OK 

 

 
Arrange Windows dialogue box 

Compare Worksheets Side by Side 

If you open two workbook windows, you can set both windows to scroll simultaneously (so if 

you scroll down in one window, the content of the other is redrawn too). 

To compare worksheets side by side 
 With the workbooks you want to compare open and the first workbook selected, from 

the Window menu, select Compare Side by Side With... 

 If there are more than two workbooks open, select the file with which you want to 

compare the current workbook 

The windows of the workbooks are displayed together and the Compare Side by Side 

toolbar is displayed. You can edit either workbook by clicking it then editing as normal. When 

the Synchronous Scrolling button  is active, scrolling in one window scrolls the other 

automatically. 
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 From the toolbar or Window menu, click Close Side by Side to finish (this does not 

close either workbook) 

Note Only scrolling is simultaneous. If you switch to a 

different worksheet in one window, you must do so 

manually in the other window. 

 

Hide and Unhide Data 

You may want to hide a part of a worksheet because it contains sensitive information or 

intermediate calculations that do not need to be seen or printed. The contents of columns, 

rows, worksheets, and whole workbooks can be hidden. Even though it is not shown, a hidden 

cell is calculated as normal if it is used in a formula.  

You can also hide columns and rows temporarily to make more room on-screen. 

To hide columns, rows, and worksheets using the mouse 
 Select the column(s), row(s), or worksheet(s) to hide 

 From the Format menu, select Row, Column, or Sheet then from the submenu, select 

Hide  

OR 

 Right-click the selection then from the shortcut menu, select Hide 

To hide a workbook 

You might want to hide a workbook if you create formulas in one book that link to data in a 

second book that you want to keep confidential. 

 Open the workbook 

 From the Window menu, select Hide 

Note When you exit Excel, you will be prompted to save any 

changes to the hidden workbook. When you open a 
hidden workbook, the workbook window remains 

hidden. 

 

To unhide columns or rows using the mouse 
 Select a group of columns or rows that span the hidden columns or rows 

 From the Format menu, select Row or Column then from the submenu, select 

Unhide OR right-click the selection then from the shortcut menu, select Unhide 

 

Tip To unhide all columns or rows, select the entire 

worksheet then from the Format menu, select Row or 

Column then from the submenu, select Unhide. 
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To unhide a worksheet 

 From the Format menu, select 

Sheet then select Unhide... 

The Unhide dialogue box is displayed. 

 Select the worksheet to unhide 

 Click OK 

 
Unhide dialogue box 

 

To unhide a workbook 
 From the Window menu, select Unhide 

 From the Unhide dialogue box, select the workbook to unhide and click OK 

 

Note You will notice a workbook named PERSONAL in the list 

of books. This is used to store macros and should not be 

unhidden. 

 

To hide and unhide columns or rows using the keyboard 

 

Press To 

Ctrl + 0  (zero) Hide selected 

column(s) 

Ctrl + Shift + )  Unhide selected 

column(s) 

Ctrl + 9  Hide selected row(s) 

Ctrl + Shift + (  Unhide selected row(s) 

 

Exercise 33 

 Open the workbook CONTACTS then click in cell C2 then from the Window menu, 

select Freeze Panes 

 Scroll around the sheet, noticing that the titles always remain on the screen 

 Select column A then from the Format menu, select Column then select Hide  
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 Click the ContactData sheet tab to select the worksheet 

 Click in cell A2 then press Ctrl + Shift +   to select the range of data 

 Press Shift +    twice to select the next two columns 

 From the Insert menu, select Names then Create 

 In the dialogue box, make sure that only the Left column box is checked then click OK 

 Click in cell A2 then from the Window menu, select Freeze Panes 

 Click the arrow on the Name box then scroll to find Merchant,Robb and select it 

The appropriate data is selected on the sheet. 

 From the Edit menu, select Go To then select another name and click OK 

 Select the sheet CompleteData 

 Select rows 86:92 then right-click the selected row headers and select Hide 

 Note the total number of rows with data in CompleteData then switch back to 

ContactData then look to see if the hidden rows are still shown 

Hiding data does not affect any calculations using the hidden cells. Because all the cells on the 

ContactData sheet use a reference to CompleteData, all the rows are still there. 

 Switch back to the CompleteData sheet and click-and-drag across rows 85:93 

 Right-click the row headers and select Unhide 

 From the Format menu, select Sheet then from the submenu, select Hide  

 Save and close the workbook 

Open HOUSE 

Open HOUSEHOLD 

 Practise switching between the two workbooks 

 From the Window menu, select Compare Side by Side With... 

 Practise scrolling around one window and observe the changes in the other window 

 On the Compare Side by Side toolbar, click Close Side by Side 

 Close HOUSEHOLD 

 Maximise HOUSE 

 Use the horizontal split box to split the screen into two so that you can view the fixed 

and variable expenses on the screen together 

 Remove the split 

 Use Freeze Panes to lock the Month headings for scrolling across the sheet 

 Remove the split 

 Use Zoom to view all data on the worksheet without scrolling 

 Save and close HOUSE 

About places to save files 
Some of the content in this topic may not be applicable to some languages. 

You can save the file you're working on, whether it's new or has been saved before, and you 

can also save a copy of the file with a different name or in a different location. You can save 

any file as a Single File Web Page (MHTML) so that it can be viewed and used on the Internet. 
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My Documents 

When you open the Open and Save As dialog boxes after starting a Microsoft Office program, 

the My Documents folder appears by default. The My Documents folder is a good place to save 

files you're working on, such as documents, worksheets, or databases. 

My Network Places 

My Network Places, which is located on the My Places bar in the Open and Save As dialog 

boxes, is a good place to save files you want to copy or publish to folders on network file 

servers or Web servers. Saving files to a server allows others easy access to them. 

Change the default working folder 

This procedure sets the default folder for opening and saving Microsoft Excel files. 

1. On the Tools menu, click Options, and then click the General tab.  

2. In the Default file location box, type the path for the folder you want to display as 

the default working folder.  

For example, type c:\work. 

About file properties 

Document properties are details about a file that help identify it— for example, a descriptive 

title, the author name, the subject, and keywords that identify topics or other important 

information in the file. Use document properties to display information about a file or to help 

organize your files so that you can find them easily later. You can also search for documents 

based on document properties. 

Types of document properties 

There are four types of document properties:  

 Automatically updated properties include statistics that are maintained for you by 

Microsoft Office applications, such as file size and the dates files are created and last 

modified. For example, you can search for all files created after March 3, 1999, or for all 

files last modified yesterday.  

 Preset properties already exist (such as author, title, and subject), but you must enter 

a text value. For example, in Microsoft Word, you can use the Keywords property to 

add the keyword "customers" to your sales files and then search for all sales files with 

that keyword.  

 Custom properties are properties you define. You can assign a text, time, or numeric 

value to custom properties, and you can also assign them the values "yes" or "no." You 

can choose from a list of suggested names or define your own. You can optionally link 

custom document properties to specific items in your file, such as a named cell in 

Microsoft Excel, a selected item in PowerPoint, or a bookmark in Word. For example, in a 

contract form created in Word, you can create a custom file property that is linked to a 

form field that contains the contract's expiration date. Then you can search for all 

contract files with expiration dates earlier than the date you specify.  

 Document library properties are for files in a document library on a Web site or 

public folder. When you design a document library, you define one or more document 

library properties and set rules on their values. When users add documents to the 

document library, they are prompted to fill in a form assigning values to each of these 
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properties. For example, a document library that collects product ideas could prompt the 

user for properties such as Submitted By, Date, Category, and Description.  

Setting document properties 

You can set document properties for the active file you're working on in any Microsoft Office 

application. If you want to be reminded to set document properties for every file you create, 

you can have Microsoft Excel, Word, or PowerPoint automatically display the Properties dialog 

box when you save files for the first time. When you add a file to a document library, you are 

automatically prompted for the file's document library properties. 

Viewing document properties 

If a document is open, you can view its properties by using the Properties command. 

You can view the properties of any document by selecting the document in Windows Explorer 

or in the Open, Save, or Search dialog boxes. When you view a document library listing in a 

Web browser, each document name is listed along with its document library properties. 

Create custom file properties 
 On the File menu, click Properties.  

 Click the Custom tab.  

 In the Name box, type a name for the custom property, or select a name from the list.  

 In the Type box, click the data type for the property you want to add.  

 In the Value box, type a value for the property. The value you enter must match the 

selection in the Type box. For example, if you click Number in the Type box, you must 

type a number in the Value box. Values that don't match the property type are stored 

as text.  

 Click Add.  

Switch Between Worksheets 

The Sheet tab at the bottom of the worksheet window identifies each sheet within the 

workbook.  

To select a worksheet using the mouse 
 Clicking the worksheet's tab 

The sheet scroll buttons allow viewing of sheet tabs that extend beyond the tab space. 

 
Sheet tabs 

Sheet 
tabs 

Sheet 
scroll 

buttons 

Split box 
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Tip To change the size of the area showing sheet tabs, click-

and-drag on the split box. 

 

To group worksheets using the mouse 

Some operations require you to select multiple worksheets. When you select additional sheets, 

the first sheet in the selection remains active. The active worksheet's name is shown in bold. 

 Open the workbook containing the worksheets to be printed 

 To activate and group the worksheets together for printing, do one of the following 

To Select Click 

Two or more adjacent 

worksheets 

The worksheet tab of the first worksheet to activate it. Press and hold 

down the Shift  key, and click the last tab in the range of 

worksheets you want to select. 

Two or more non-

adjacent worksheets 

The worksheet tab of the first worksheet to activate it. Press and hold 

down the Ctrl  key, then click the tabs of the other worksheets you 

want to select 

 
Grouped adjacent worksheets 

 
Grouped non-adjacent worksheets 

 

Tip  When multiple worksheets are selected, the word 

[Group] is displayed in the workbook title bar. 

 

To ungroup worksheets 

 Hold down the Shift  key, and click on the active worksheet tab to ungroup all the 

worksheets 

To select and group worksheets using the keyboard 

 Press Ctrl + Page Down  and Ctrl + Page Up  to select the next and previous 

worksheets respectively 

 Press Shift + Ctrl + Page Down  and Shift + Ctrl + Page Up  to select multiple 

worksheets 

To enter data on multiple worksheets 

When you have selected multiple sheets, if you type or paste data into a cell, the same data is 

inserted into each cell on each selected worksheet. 

You can also use the AutoFill command to copy a series or existing data onto multiple 

worksheets.  

 Select the worksheet containing the data or start of the series that you want to copy 
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 Select the additional worksheets to copy data to 

 Select the range of cells from which to copy data (or the cell with the series origin and 

the cells to fill) 

 From the Edit menu, select Fill then Across Worksheets... 

The Fill Across Worksheets dialogue box is displayed. 

 

 
Fill Across Worksheets dialogue box 

 

 Select whether to copy All or either Contents or Formats 

 Click OK 

Copy Cells and Data between Worksheets and Workbooks 

Data can be moved or copied between different worksheets and workbooks using the Cut, 

Copy, and Paste tools. 

To move or copy a cell or range to a different worksheet 

Cutting and pasting is a single action, and the cut cells can only be pasted once. The cell 

contents can be moved within the same worksheet or to other worksheets. After copying, the 

selection remains highlighted and may be pasted multiple times. 

 Select the range to be move/copy (this can be a single cell, block of cells, column(s) or 

row(s))  

 From the Edit menu, select Cut (SpeedKey: Ctrl + X ) or Copy (SpeedKey: Ctrl

+ C ) 

 Click the tab to select the worksheet that you want to move/copy data to 

 On the new worksheet, select a cell to be the new location for the data 

If you are moving/copying a range of cells, select the cell that will become the top-left corner 

of the range.  

 From the Edit menu, select Paste (SpeedKey: Ctrl + V ) 
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Copying data from a worksheet to cell B2 and using the Paste Options SmartTag 

 

If you copied the range, the Paste Options smart tag is displayed. This allows you to choose 

formatting options (such as pasting values only, pasting formats only, retaining column widths 

and so on). There is also an option to link the cells, which has the same result as the transfer 

data formula described above or the Paste Special option (described below). 

To move or copy a cell or range to another open workbook 
 Open the source and destination workbooks 

 In the source workbook, select the range to be move/copy (this can be a single cell, 

block of cells, column(s), or row(s)) 

 From the Edit menu, select Cut (SpeedKey: Ctrl + X ) or Copy (SpeedKey: Ctrl

+ C ) 

 Switch to the destination workbook using the Window menu or Taskbar  

(SpeedKey: Alt + Tab ) 

 In the destination workbook, click the tab to select the worksheet that you want to 

move/copy data to 

 Select a cell to be the new location for the data 

If you are moving/copying a range of cells, select the cell that will become the top-left corner 

of the range.  

 From the Edit menu, select Paste (SpeedKey: Ctrl + V ) 

If you copied the range, the Paste Options smart tag is displayed. This allows you to choose 

formatting options (such as pasting values only, pasting formats only, retaining column widths, 

and so on). There is also an option to link the cells. This pastes the formula =CellReference 

into the destination cell. 

 

To move or copy cell contents 
between worksheets and 

workbooks 
 If you do not want to move cells, you can click-

 
Selecting cell contents to cut and 

paste 
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and-drag to select text within the cell or formula 

bar then cut and paste it to another location as 

normal 

Insert a New Worksheet 

A new workbook contains three worksheets named Sheet1, Sheet2, and Sheet3. Additional 

sheets may be added or existing sheets duplicated up to a total of 255. Sheets not required 

can be deleted. Sheets can be renamed and colour-coded to identify them clearly. You can 

move and copy sheets into a different sequence in the workbook. 

Worksheets make it easier to store related data together in one file. For example, if you had a 

series of monthly sales reports, you might store the monthly data for each year on 12 sheets 

in 1 workbook. 

To add a new worksheet 

 From the Insert menu, select Worksheet (SpeedKey: Shift + F11 ) 

A new sheet is inserted before the current sheet, and given the next sheet number in 

sequence.  

OR 

 Right-click a Sheet tab and from the shortcut menu, select Insert... 

The Insert dialogue box is displayed. 

 

 
Insert dialogue box 

 Select the Worksheet icon 

 Click OK 

A new sheet is inserted before the current sheet, and given the next sheet number in 

sequence.  
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Move, Copy, Rename, and Delete a Worksheet 

To copy a worksheet using drag-and-drop 
 Point to the sheet tab of the worksheet to move or copy 

 Hold down Ctrl  then click-and-drag to the left or right 

A small arrow appears above the sheet tabs. 

 
Copying a worksheet  

 

 Release the mouse to insert the duplicate sheet where the arrow is positioned 

The new sheet has the same name as the original, with a number after it to identify it as a 

duplicate. For example, if the original sheet is named Summary, the duplicate is named 

Summary (2). 

To move a worksheet using drag-and-drop 
 Position the pointer over the worksheet tab to move then click-and-drag to move the 

sheet 

A small arrow appears above the sheet tabs. 

 Release the mouse to move the 

sheet to where the arrow is 

positioned  
Moving a worksheet  

 

To move or copy a worksheet using the Move or Copy 
dialogue box 

You can move or copy a worksheet within the same workbook, to another open workbook, or 

to a new workbook. 

 Optionally, open the workbook you want to copy the sheet to then switch back to the 

source workbook 

 Point to the sheet tab of the worksheet to move or copy 

 From the Edit menu, select Move or Copy Sheet... 

OR 

 Right-click the selected tab and from the shortcut menu, select Move or Copy... 

The Move or Copy dialogue box is displayed. 
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Move or Copy dialogue box 

 

 Optionally, from the To book: list box, select the name of another open workbook or 

select (new book) to create a new workbook and move/copy the sheet to it 

 From the Before sheet: box, select a location for the sheet 

 To copy the sheet, click the Create a copy check box 

 Click OK 

Note When you copy a worksheet, any data on the worksheet 

is also copied. However, if any cells contain more than 

255 characters, only the first 255 characters will be 
copied. A warning dialogue box is displayed if this is the 

case. 

 

To rename a worksheet 
 Select the worksheet tab to rename 

 Double-click on the sheet tab 

OR 

 From the Format menu, select Sheet then Rename 

OR 

 Right-click the selected tab and from the shortcut menu, select Rename 

 Type the new name on the highlighted sheet tab and press Enter  

To change the colour of a worksheet tab 
 Select the worksheet tab 

 From the Format menu, select Sheet then Tab Color... 

OR 

 Right-click the selected tab and from the shortcut menu, select Tab Color... 

The Format Tab Color dialogue box is displayed. 
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Format Tab Colour dialogue box 

 

 Select a colour from the colour palette 

 Click OK 

To see the colour more clearly once applied, click onto another worksheet tab, as a selected 

worksheet tab is still displayed as white. 

To delete a worksheet 
 Select the worksheet tab to delete 

 From the Edit menu, select Delete Sheet 

OR 

 Right-click the selected tab and from the shortcut menu, select Delete 

If there is any data on the sheet, a warning dialogue box is displayed. 

 

 

 

 Click Delete 

 

Warning You cannot undo this command, so data on the 

sheet will be deleted permanently unless you close the 

workbook without saving changes. 
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Exercise 34 

 Open the workbook STRUCTURE HOUSE 

 Insert a new row between Income and Husband and choose Format Same As 

Below from the Paste Options smart tag 

 Insert a new row between Expenses and Mortgage and choose Format Same As 
Below from the Paste Options smart tag 

 Insert a new column between columns A and B and choose Format Same As Right 
from the Paste Options smart tag 

 Delete column B 

 Rename Sheet 1 as Expenses 

 Make the sheet Expenses colour Pale Blue 

 Select rows 1 to 8 then click Copy  

 Click the Sheet2 tab 

 Click Paste  

 From the Paste Options smart tag, select Keep Source Column Widths 

 Rename Sheet2 to Income and apply the Pale Yellow colour 

 Delete Sheet 3 

 Right-click the Expenses sheet and select Move or Copy... 

 Move to the end of the workbook and make it a copy 

 Click the original Expenses sheet and delete rows 2 to 8 

 Save and close the workbook 

Printing 

Set margins for printing 

Select the worksheet or worksheets you want to print. 

When you enter or change data, the changes affect all selected sheets. These changes may 

replace data on the active sheet and other selected sheets. 

To select Do this 

A single sheet 

Click the sheet tab.  

If you don't see the tab you want, click the tab scrolling 

buttons to display the tab, and then click the tab. 

Two or more adjacent sheets 
Click the tab for the first sheet, and then hold down SHIFT 

and click the tab for the last sheet. 

Two or more nonadjacent 

sheets 

Click the tab for the first sheet, and then hold down CTRL and 

click the tabs for the other sheets. 

All sheets in a workbook 
Right-click a sheet tab, and then click Select All Sheets on the 

shortcut menu 
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Note If sheet tabs have been colour-coded, the sheet tab name 

will be underlined in a user-specified colour when 

selected. If the sheet tab is displayed with a background 

colour, the sheet has not been selected. 

Set page margins 
 On the File menu, click Page Setup, and then click the Margins tab.  

 In the Top, Bottom, Left, and Right boxes, enter the margin size you want. 

 To apply the same page margins to new worksheets or workbooks, you can create a 

worksheet or workbook template. 

Set header or footer margins 
 On the File menu, click Page Setup, and then click the Margins tab.  

 To change the distance from the top edge to the header, enter a new margin size in the 

Header box.  

 To change the distance from the bottom edge to the footer, enter a new margin size in 

the Footer box. 

These settings should be smaller than your top and bottom margin settings, and larger than or 

equal to the minimum printer margins. 

Tip To see how the margins will affect the printed 

document, click Print Preview before the document is 

printed. To adjust the margins in print preview, click 
Margins, and then drag the black margin handles on 

either side and at the top of the page 

 

Insert date and time in a header or footer 
 On the View menu, click Header and Footer.   

 Click Custom Header or Custom Footer.  

 Click in the Left section, Center section, or Right section box.  

 On the row of buttons in the Header or Footer dialog box, click Date or Time.  

 If you want, do one or more of the following:  

 To start a new line, press ENTER. 

 To delete a date or time from a header or footer, select &[Date] or &[Time] and then 

press DELETE. 

Note  Make sure the header or footer margin allows enough 

space for the custom header or footer 
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Add headers and footers for printing 
 Click the worksheet.  

 On the View menu, click Header and Footer.  

 In the Header or Footer box, click the header or footer you want.  

Create custom headers and footers 

You can have only one custom header and one custom footer on each worksheet. If you create 

a new custom header or footer, it replaces any other custom header or footer on the 

worksheet. 

 Click the worksheet.  

 On the View menu, click Header and Footer.  

 To base a custom header or footer on an existing header or footer, click the header or 

footer in the Header or Footer box.  

 Click Custom Header or Custom Footer.  

 Click in the Left section, Center section, or Right section box, and then click the 

buttons to insert the header or footer information you want in that section.  

 Do one or more of the following:  

 To enter additional text for the header or footer, enter the text in the Left section, 

Center section, or Right section box.  

 To start a new line in one of the section boxes, press ENTER. 

 To delete a section of a header or footer, select the section that you want to delete 

in the section box, and then press BACKSPACE. 

Note  You can use the buttons in the Header or Footer dialog 

boxes to format or further customize your headers and 
footers. Make sure the header or footer margin allows 

enough space for the custom header or footer. 

 

Print a worksheet to fit a paper width  
 Click the worksheet.  

 On the File menu, click Page Setup, and then click the Page tab.  

 Under Scaling, click Fit to.  

 In the first box beside Fit to, enter 1 (for 1 page wide).  

 In the second box beside Fit to, delete the value so that the number of pages tall is 

unspecified. 

Print a worksheet on a specified number of pages 
 Click the worksheet.  

 On the File menu, click Page Setup, and then click the Page tab.  

 Under Scaling, click Fit to.  

 In the boxes beside Fit to, enter the number of pages on which you want to print the 

work. 
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Notes 

 Microsoft Excel ignores manual page breaks when you use the Fit to option.  

 When you change the values for Fit to, Excel shrinks the printed image or expands it 

up to 100 percent, as necessary. To see the how much the image will be adjusted for 

your new values, click OK, and then click Page Setup on the File menu. The Adjust 

to box on the Page tab shows the percentage that the printed size will be adjusted.  

 Printed data does not exceed the specified number of pages. Excel does not enlarge the 

data to fill the pages 

Print with or without cell gridlines 
 Click the worksheet.  

 On the File menu, click Page Setup, and then click the Sheet tab.  

 Select or clear the Gridlines check box.  

 Click Print.  

Note  Worksheets print faster if you print without gridlines. 

Print row and column headings or labels on every page 

Row headings are the row numbers to the left of the worksheet; column headings are the 

letters or numbers that appear at the top of the columns on a worksheet. 

Print row and column headings 
 Click the worksheet.  

 On the File menu, click Page Setup, and then click the Sheet tab.  

 Select the Row and column headings check box, and click Print.  

Print row and column labels on every page 
 Click the worksheet.  

 On the File menu, click Page Setup, and then click the Sheet tab.  

 To print column labels on every page, under Print titles in the Rows to repeat at 

top box, enter the rows that contain the column labels, and then click Print.  

 To print row labels on every page, under Print titles in the Columns to repeat at left box, 

enter the columns that contain the row labels, and then click Print. 
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Print Preview 

Exercises 35 

Whenever you want to print a worksheet, always first go to print preview to see what your 

worksheet will look like when it is printed.  

Save your worksheet and then go to the File, Print Preview menu. 

Zoom  

Use this to zoom in and out of your document. Click on Zoom and Excel will zoom into your 

document. When you click on Zoom again, Excel will zoom out of the document. 

 

 

 

Setup 

Controls the appearance of the printed document.  

 Click on Setup and change the Page orientation of your worksheet from Portrait to 

Landscape.  

 You do this by clicking on Landscape and then clicking OK. When you work in Excel you 

will from time to time have a wide document that you will want to print in Landscape 

format. 

Page Break Preview 

This gives you a view of all the pages of your worksheet and where they will be cut off. 

Click on Page Break Preview. You will notice that this option takes you out of Print Preview and 

back to your worksheet.  
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Printing The Document 

Exercises 36 

 Choose the File, Print menu. You now have a couple of choices.  

 In the Print Range box you can choose to print either all the pages or only certain pages 

of the workbook.  

 In the Copies box, you can choose the number of copies of the printing job you want to 

print. 

 There is also a Print What box, which gives you the following options: the entire 

workbook or only selected worksheets. If you choose active sheets, the work area of 

selected sheets only will be printed. If you choose Entire workbook, Excel will print the 

entire workbook. 
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MANIPULATE DATA 
 

 

Specific Outcome 

Manipulate the data in a spreadsheet 

 

 

Assessment criteria 

 The appearance of spreadsheet is modified to user requirements using formatting 

facilities: Alignment, cell widths, text style, font, colour, number, date and time formats 

 Selected cells within an existing spreadsheet file are sorted numerically and 

alphabetically 
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Set Up a Data List 
In addition to performing calculations, spreadsheets can also be used to work with long lists of 

data.  

Two database terms that are useful to know are Record and Field. 

 A record is all of the data on a single row 

 A field is each separate column along the record 

Fields have column headings (or titles/labels) at the top to identify the type of data that should 

be entered in the field. 

 

 
Example list containing seven fields and fourteen records 

 

Lists can be created and used with or without a heading row; Excel will recognise and use it if 

it is there, but formatting the heading row differently from the rest of the list helps to make it 

obvious to users. A blank row or column denotes the end of a list. 

To define a range as a list 

You can also define an area of a worksheet as a list. This has the advantage of making Excel's 

list tools available when the list is selected. It also makes it easier to manage multiple lists on 

a single worksheet. For example, if you store two or more lists next to one another, to protect 

the lists, Excel prevents you from inserting or deleting a row in the normal way. Instead, you 

must right-click within a list to select the insert or delete command, which then only inserts or 

deletes cells in the active list. 

 

Note This feature is not available in the Basic edition of Excel 

(the version that ships with Office Basic, Standard, and 

Small Business editions). 

 

 Select the range containing the data for the list 



 Page 113 

Normally, the list should include labels (or headers) in the top row to identify each column 

(field). If the list does not have headers, Excel will insert default headers (Column1, 

Column2, and so on) when you create the list. 

 From the Data menu, select List then Create List... (SpeedKey: Ctrl + L ) 

The Create List dialogue box is displayed. 

 

 
Create List dialogue box 

 If necessary, adjust the range comprising the list 

 Optionally, uncheck the My list has headers box (if your list does not have labels) 

 Click OK 

The list is shown with a blue border. When the list is selected (active), a blank row at the end 

of the list is shown with an asterisk, which you can use to add rows (records) to the list. 

Arrows are shown on each header cell. These allow you to apply an AutoFilter to the list. 

 

If you click away from the list, it becomes inactive. When a list is inactive, the AutoFilter 

arrows and the new record indicator are hidden. By default, inactive lists are shown with a thin 

blue border. 

 

Tip To show or hide the border around inactive lists, right-

click a list and select Hide Border of Inactive Lists. 
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Tip You can also create a list by right-clicking a range and 

selecting Create List from the shortcut menu. 

 

To re-define a list 

You can add rows to the same list by typing in the asterisk row. You can also insert rows, 

columns, or cells within a list using the normal Insert Cells command. Finally, if you type in a 

blank column to the right of a list, the column will be added to the list automatically (you can 

change this using the AutoCorrect SmartTag). 

 To change the range used for a list (for example, to make the list smaller), right-click 

the list and select List then Resize List... 

 Click-and-drag a new range for the list and click OK 

To remove a list 

Removing the list property from a range does not delete any data from the cells. 

 Right-click the list and select List then Convert to Range 

 Click Yes to confirm 

Use a Form to Enter and Edit Data 

Lists can be displayed on a data form. Records can be viewed, sorted, selected, added, edited, 

and deleted from the form instead of directly on the worksheet. This can save time and effort 

in scrolling around long or wide lists. Adding new records on the form adds them to the bottom 

of the list automatically. 

To edit records using a data form 

 Click any cell in the list 

 From the Data menu, select Form... 

The Form dialogue box is displayed for the selected list, showing record number 1. 

Fields that can be edited appear as boxes. Calculated fields (formulas) display a value on the 

form background, and cannot be edited. 

 Select the record to amend by using the scroll 

bar or the Find Prev or Find Next buttons 

 Edit any of the displayed fields 

 Press Tab  to advance to each field to edit

  

 Press Enter  to save the changes 

 Click Close to return to the worksheet 
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Form option buttons 

 

Button  Action 

New Add a new record. A blank form is displayed. Enter the details 

and press Enter  to save the record and start a new one. 

Delete Delete the displayed record. Confirmation is requested before 

the record is deleted. 

Restore Cancel changes made to the current record before they are 

saved. 

Find Prev Move back to the previous record in the list. 

Find Next Advance to the next record in the list. 

Criteria Find a record. Displays a blank form for entering search 

criteria. 

Close Close the form and return to the worksheet. 

To find a record 
 From the Form dialogue box, click the Criteria button 

A blank form is displayed, with selection boxes for all fields including calculated fields. 

 

 
Criteria form 

 Enter the search criteria in each field required 

 Click the Find Next or Find Prev buttons 
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The number of records matching the criteria is displayed at the top of the dialogue box, for 

example 4 of 40. 

Criteria option buttons 

 

Button Action 

Clear Clear fields - clears data from all of the fields ready for a new 

search. 

Restore Cancel changes made to the current criteria selection. 

Find Prev Move back to the previous record that meets the selection 

criteria. 

Find Next Advance to the next record that meets the selection criteria. 

Form Close the Criteria, and return to the form. 

Close Close the Form and return to the worksheet. 

 

Sort a List 

Lists can be sorted by using the toolbar buttons or the menu. Excel will find and sort any data 

adjacent to the active cell. 

To sort by a single column 

 Click in a single cell in the column to sort by - for example, click in B1 to sort by 

column B 

 On the Standard toolbar, click Sort Ascending  or Sort Descending  

The entire list is selected, and then sorted by the chosen column. 

 

 
List sorted by Company in ascending order (alphabetical sort) 
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List sorted by Total in descending order (numeric sort) 

 

Warning Selecting more than one cell will limit the sort area 
to the selection only.  

For example, if you selected column A in the worksheet 
shown above, column A would be sorted alphabetically 

but column B would not change. Consequently, the 
wrong quantity would be shown next to each type of 
fruit. This would be a very serious error and very 

difficult to put right without using Undo. 

 

To sort a range or a list 

 

 

Do not select a range before applying a sort (unless that is what you intend to do). If you 

select a range, only the cells within that range will be sorted. To sort a column, you 

only need to click in one cell in that column. 

If you do select a range, and there is data in columns or rows adjacent to your selection, Excel 

will warn you that it thinks you might have made a mistake. 

 If appropriate, click Expand the selection to select the whole list then click Sort... 
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Note If you select part of a defined list (that is, a list with a 

blue border), Excel expands the selection to the whole 

list without prompting you. 

 

Sort Orders 

When a list is sorted in ascending order, Excel sorts the list using the following rules. Blank 

cells always appear at the bottom of the list. 

 

Data Type Ascending Sort Order 

Numeric Smallest negative number to largest positive number. 

Date/Time Earliest date/time to latest date/time. 

Text Sorted left to right, character by character using the 

following order of precedence: 

0 1 2 3 4 5 6 7 8 9 (space) ! " # $ % & ( ) * , . / : ; ? @ [ \ 

] ^ _ ` { | } ~ + < = >  

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 

Apostrophes and hyphens are ignored unless two cells are 

identical except for the presence of an apostrophe or 

hyphen. For example, Co-ordinator follows Coordinator. 

Boolean FALSE then TRUE. 

 

The sort orders listed above are reversed in a descending sort. However, blank cells still 

appear at the bottom of the list, even in a descending sort. 

If the range contains mixed data types, it will be sorted in the order shown above (that is, 

numeric values appear at the top, followed by dates, then text, and finally Boolean values). If 

your list contains numbers that should be sorted as text, format the cells as Text first 

(Format, Cells, Number tab). 
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To sort by more than one column 

 Click in a single cell in any column 

in the list - do not select more 

than one cell 

 From the Data menu, select 

Sort... 

The Sort dialogue box is displayed.  

 Click the arrow and select a column 

heading for each sort required 

 

 
Sort dialogue box 

 

 

Tip If column labels are not displayed in the Sort by boxes, 

check that the Header row option is selected. 
Conversely, if your list or selection does not have column 

labels, make sure the No header row option is selected. 

 

 Click the Ascending or Descending option buttons for each sort selected 

 Click OK 

 

Tip If more than three columns need to be sorted on, select 
and sort on the three least important columns first, then 

the more important ones next. 

 

Tip If you want to sort data in a row, make your selection 

then click the Options button. In the Sort Options dialogue 

box, select Sort Left to Right then click OK. Complete the 

Sort dialogue box as normal. 
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Filter a List 

Filtering selects and displays only the required records on the screen. Filters can be applied to 

several columns in succession, reducing the number of records displayed each time. Lists can 

be sorted before or after filtering, and they print out as they appear on the screen. 

To filter a list 

Filtering selects only records that meet specific criteria, such as a name, date, or value, and 

hides the others by setting the row size to 0 (zero). Filter buttons list every different value that 

can be selected within the column. 

 Click anywhere in the list 

 From the Data menu, select Filter... then from the submenu select AutoFilter 

Filter buttons are displayed on every column in the list. 

 

 
Filter buttons 

 

Tip If you define a list, AutoFilter buttons are shown 

automatically when you select the list. 
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 Click a filter button and select a value from the list box 

 

 
Filter list 

The filtered data displays only lines containing the selected item. The filter button turns blue 

on columns where items are selected. 

 Repeat for each column to select from 

 

Tip You can also use the AutoFilter menus to sort a list by 

that column. 

Exercise 37 

 Create a new workbook and save it as PRODUCT MANIFEST 

 Type the following field names into separate cells in row A: ID, Category, Product, 

Amount, Price, Stock Level, Reorder Level, Discontinued 

 Select the ID, Stock Level, and Reorder Level columns then apply Number value 

format with No Decimal Places and No comma separator, apply Currency format, 

with £ symbol and 2 decimal places to the Price field then apply a dd/mm/yyyy 

format to the Discontinued column 

 Right-click A1 and select Create List..., check the My list has headers box and click 

OK 

 To start, click in A2 then add the following records to the list, taking care to type the 

data accurately 

 

ID Category Product Amount Price Stock Level Reorder 

Level 

2220

0 

Condime

nts 

Redcurrant Sauce 6 x 

150ml 

£6.35 86 0 

2220

1 

Condime

nts 

Redcurrant Sauce - 

Extra Jelly 

1 x 1kg £6.30 24 5 

2220

2 

Salads Rice & Vegetable 

Salad 

2kl £7.35 11 25 

2220 Chilli Roadhouse Hot & 6x147ml £10.29 20 0 
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3 Sauces Spicy 

2220

4 

Chilli 

Sauces 

Roadhouse Original 6x147ml £10.29 61 25 

2220

5 

Chilli 

Sauces 

Roadhouse 

Southwest BBQ 

6x147ml £10.29 49 30 

 

 From the Data menu, select Form... 

 Use the form to add the following records 

 

ID Category Product Amount Price Stock Level Reorder 

Level 

2220

6 

Cold 

Meats 

Roast Beef Per kilo £6.30 13 25 

2220

7 

Bread Rossini Curls 1 x 280 £14.75 20 10 

2220

8 

Salads Russian Salad 2kl £5.20 15 0 

2220

9 

Herbs & 

Spices 

Saffron Powder 

Packets 

100 x 

0.125g 

£53.15 86 0 

2221

0 

Cold 

Meats 

Salami Milano Per kilo £12.40 35 0 

2220

6 

Cold 

Meats 

Roast Beef Per kilo £6.30 13 25 

 

 Use the scroll bar to move to record #6 

 Change the price to £8.29, the Stock Level to 10, and the Reorder Level to 5 

 Click Criteria 

 In the Category field, type Chilli Sauces 

 Click Find Next 

 Change the Amount to 6x197ml then select the value and press Ctrl + V  to copy 

it 

 Change the Amount for other products in the Chilli Sauces category, using Ctrl

+ V  to insert the value you copied 

 Click Close 

 Click the arrow on the Category field and select Cold Meats 

 Click the Stock Level label 

 On the Standard toolbar, click Sort Ascending  
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 Click in the Discontinued field for the first record in the filtered list 

 Type today's date 

 Use AutoFill to copy the date to the next two records 

 Click the arrow on Category and select (All) to remove the filter 

Notice that AutoFill only operates on the records selected by the filter. 

 Click in a single cell in any column in the list - do not select more than one cell 

 From the Data menu, select Sort... 

 In the first box, select Category and Ascending order 

 In the second box, select Price and Descending order 

Note that because this is a defined list, Excel greys out the Header row/No header row 

options so that you cannot change them. 

 Click OK 

 Save and close the workbook 

 

Open the workbook DATALIST 

 Use the Sort buttons to order the data in date sequence with the most recent Invoice 
first 

 Sort the data alphabetically by Company 

 With the cell pointer in any cell within the table, from the Data menu, select Sort... 

 Sort the data by Amount within Company 

 Sort the data by Date and Company putting the oldest invoice at the top of the list 

 Sort the data into Company order then, for each company, sort the data into Total 
order 

 Switch to Form view 

 Find all orders for 29th September 2003 

 Find all orders for the company named Lectern Systems 

 Save and close the workbook 

Open the workbook PRODUCT DATALIST 

 Use Sort and filter to answer the following questions 

 

Question Answer 

How many product categories are there?  

What is the most expensive product?  

What is the lowest number of units in stock (ignoring 

zero values)? 

 

What is the most expensive product in the Dairy 

category? 

 

What is the eighth most expensive product?  
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How many different products come in ten 500g 

packets? 

 

What is the price of Chocolade?  

 

 Remove all filters and hide the AutoFilter arrows 

 Sort the list by ProductID in Ascending order 

 Close the workbook 

 

Borders and Shading 
Cell shading and borders can be used to highlight selected areas of the sheet; for example, to 

identify where you should or should not enter data. Commonly, cells containing formulas (such 

as row or column totals) are shaded differently or marked by a border from the cells containing 

the data they calculate. 

 

 

When you design a spreadsheet, you should always bear in mind that you might not be the 

only person who has to use it. Effective use of borders and shading can improve the usability 

of a complex worksheet.  

If you want to apply formats quickly, the AutoFormat feature gives you the option of simply 

choosing from a range of predefined formats. 

Apply Cell Borders 

Borders and shading can be used to mark out different areas of the worksheet, making it 

easier to edit and read data. A variety of different border and shading line styles, colours, and 

patterns is available. 

To add a border using the Formatting toolbar 

 Select the cell(s) to which to add borders 

You can apply a border to a single cell, a range, or whole rows/columns. If you select a block 

of cells, you can apply borders to the inside and outside edges of the selection. 

 On the Formatting toolbar, click Border  to apply the border style shown, or 

click the arrow on the Border button to select a border style from the menu 
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Border pull-down menu 

To draw a border 

The Borders toolbar contains a Draw Borders tool, much like the Draw Table tool in Word. 

 From the View menu, select Toolbars... then select Borders from the submenu 

OR 

 Right-click any toolbar and select Borders from the shortcut menu 

OR 

 Click the arrow on the Borders button and select Draw Borders... 

The Borders toolbar is displayed. 

 

 
Borders toolbar 

 Select a line style and colour 

 Click the Draw Border button  

The mouse pointer changes to a pen shape . 

 Click-and drag-the mouse pointer to draw borders around a block of cells 

 

 
Using the Draw Border button to draw an outside border 

 

 Click the edge of a cell to add a border to that edge only 

 

Tip You can draw diagonal borders within a cell by 

dragging from one corner to another. 

 

 Optionally, change the line style and colour to draw different borders 

Draw 
Border 

Erase 
Border 

Line Style Line 
Color 
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 To return the cursor to normal, click the Draw Border button  again (SpeedKey: 

Esc ) 

 To remove a border, click Erase Border  

The mouse pointer changes to an eraser shape . 

 Click or click-and-drag over the borders to remove 

 

Tip To draw with internal borders, click the arrow on the 

Draw Border button and select Draw Border Grid . The 

cursor changes to the following shape . You can also 

switch to the grid cursor by holding down Ctrl  or to the 

eraser cursor by holding down Shift . 

 

To add a border using the Format Cells dialogue box 
 Select the cell(s) to have borders added 

 From the Format menu, select Cells... (SpeedKey: Ctrl + 1 ) 

OR 

 Right-click the selection and from the shortcut menu, select Format Cells... 

The Format Cells dialogue box is displayed. 

 Click the Border tab 

 From the Line panel, select a line Style: 

 From the Line panel, select a border colour from the Color: pull-down list 

 From the Color: box, select a colour for the border 

 To apply the selected border, from the Presets panel, select an outline style 

OR 

 Click the buttons in the Border panel (or click the preview graphic itself) to add and 

remove borders from particular edges 
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Format Cells - Border dialogue box 

 

 

Tip The border style applied is the one selected in the Line 

panel. You can change the settings there then click in 
the Border panel to apply different border styles to 

particular edges. 

 

 Click OK 

 

Tip If you have applied borders to a worksheet, you may 

want to hide the normal sheet gridlines. From the Tools 
menu, select Options... then click the View tab. Clear the 

Gridlines check box and click OK. 

Apply Cell Shading 

If you apply shading to a cell, make sure that you also adjust the font colour if necessary. The 

text and its background should use contrasting colours to ensure legibility.  

To add shading using the Formatting toolbar 

 Select the cell(s) to have shading applied 

 On the Formatting toolbar, click Fill Color  to apply the fill colour shown 

OR 

 Click the arrow on the Fill Color button to select a fill colour from the colour palette 

Click a button or 
click on the 

graphic to add 
a border 

If more than one 
cell is selected, 
you can apply 
internal (grid) 

borders by 
clicking 

between the 
"Text" labels or by 

clicking the 
buttons Clicking a 

border  (or the 
button again) 

erases it 
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Fill Color palette 

To add shading using the Format Cells dialogue box 

 Select the cell(s) to which to apply shading 

 From the Format menu, select Cells... (SpeedKey: Ctrl + 1 ) 

OR 

 Right-click the selection and from the shortcut menu, select Format Cells... 

The Format Cells dialogue box is displayed. 

 Click the Patterns tab 

 From the Cell shading panel, select a Color: 

 Optionally, from the Pattern: box, select a pattern style 

 Click OK 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To change the font colour 
 Select the cell(s) to which to apply formats 

OR 
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 Edit the cell (press F2  or double-click) then click-and-drag to select the text to which 

to apply formats 

 On the Formatting toolbar, click Font Color  to apply the colour displayed on 

the button 

OR 

 On the Formatting toolbar, click the arrow on the Font Color button and select a 

colour from the pull-down menu 

Apply AutoFormat 

AutoFormats are a list of predefined formats to make formatting all or part of a worksheet 

easier. 

To AutoFormat a range of cells 

 Select the range to which to apply AutoFormatting 

 From the Format menu, select AutoFormat... 

The AutoFormat dialogue box is displayed. 

 

 

AutoFormat dialogue box 

 

 Scroll down through the options to view all the available AutoFormats 

 Select a formatting style from the list by clicking on it once 

 Click the Options... button to display the Formats to apply panel 

 From the Formats to apply panel, select check boxes to switch elements of the 

selected style on or off 

 Click OK 
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Exercise 38 

 Open the workbook BORDER EXPENSE FORM 

 If necessary, adjust the Zoom control so that you can see all the data 

 Insert a column to the left of column A 

 Select column A and column N 

 From the Format menu, select Column then Width and set it to 1 

 Insert a row above row 1 then another row above row 9 

 Resize rows 1, 8, and 26 to 10 

 Change the height of row 7 to 27 and change the vertical alignment to Top 

 Display the Borders toolbar 

 Select the line colour Dark Blue and a thick line then draw a border around B8:N26 

 Select a thin dashed line and draw a border on the bottom of cells D10:M10 

 Mirror this border along row 21 

 Select D22:D25 

 From the Format menu, select Cells then click the Patterns tab 

 Select the Pale Orange colour chip 

 Click the arrow on the Pattern box and select the 25% Gray pattern with Pale 
Yellow colouring 

 Click OK 

 Click in cell M24 then display the Format Cells dialogue box 

 Select the Indigo colour chip 

 Click the arrow on the Pattern box and select the 50% Gray pattern with Pale Blue 

colouring 

 Click the Border tab 

 Select the Black colour chip and a thick line weight then click the Outline button 

 Click OK 

 Change the Font Colour of M24 to White and apply Bold 

 Save and close the workbook 

Using AutoFormat 

 Open the workbook CAR SALES 

 Practise using AutoFormat to format the worksheet in different ways 
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 Save and close CAR SALES 

Open the workbook HOUSEHOLD 

 Indent the items below each subheading 

 Merge the title in cell A1 so that it spans columns A:G 

 Use the buttons on the Formatting toolbar to improve the presentation - add borders, 

shading, change number format, font styles and so on 

 

Tip Try using the Borders toolbar to create the borders! 

 

 Save and close HOUSEHOLD 

Below is an example of how the worksheet could be formatted. 

 

 

 

 


